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Software Restriction Policies Do Not Persist After You Define Them


View products that this article applies to.

Symptoms

After you define Software Restriction Policies (also known as SAFER) under the User Configuration node of your domain policy, when you later click that Software Restriction Policies container, you receive the following message in the right pane of Group Policy Object Editor:
No Software Restriction Policies Defined

Software restriction policies are not defined in this Group Policy object. If you define software restriction policies in this Group Policy object, they will override inherited policy settings from other Group Policy objects.

To define software restriction policies, in the Action menu, click New Software Restriction Policies.


This problem may also occur if you remove existing Software Restriction Policies. They may reappear after you enter the snap-in again.

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Cause

This problem occurs if you define Software Restriction Policies but if you do not change one or more of the default settings before you quit Group Policy Object Editor. In this scenario, the domain controller is not correctly updated with the information that the policy is changed.

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Resolution

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart Requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-Bit Editions
   Date         Time   Version        Size     File name
   --------------------------------------------------------------
   03-Nov-2003  18:04  5.2.3790.99    462,848  Certmgr.dll    
Windows Server 2003, 64-Bit Edition
   Date         Time   Version      Size       File name
   -----------------------------------------------------------------
   03-Nov-2003  18:05  5.2.3790.99  1,396,736  Certmgr.dll   IA-64
   03-Nov-2003  18:04  5.2.3790.99    462,848  Wcertmgr.dll  x86

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Workaround

To work around this problem, modify one of the default Software Restriction Policy rules, and then apply the changes. Reopen the Software Restriction Policy item, restore the modified rule to its default setting, and then save your changes. The domain controller is then successfully updated with the information that the policy is changed.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

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More information

For additional information about the terminology that is used to describe Microsoft product updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the Standard Terminology That Is Used to Describe Microsoft Software Updates

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Keywords: kbhotfixserver, kbqfe, kbbug, kbfix, kbqfe, kbwinserv2003presp1fix, kbautohotfix, KB830678

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Article Info
Article ID : 830678
Revision : 15
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 367