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Store databases are dismounted without warning or users cannot log on to their mailboxes in Exchange Server 2003 or in Exchange 2000 Server


View products that this article applies to.

Symptoms

In Microsoft Exchange Server 2003 or in Microsoft Exchange 2000 Server, you experience the following symptoms.

Symptom 1

You notice that Exchange store databases are dismounted without warning on a computer that is running any of the following items:
  • Microsoft Exchange Server 2003 Service Pack 1 (SP1)
  • Microsoft Exchange Server 2003 Service Pack 2 (SP2)
  • The August 2004 Exchange 2000 Server post-Service Pack 3 update rollup
When you try to mount a dismounted Exchange database in Exchange System Manager, you receive an error message that resembles the following error message:
An internal processing error has occurred. Try restarting the Exchange System Manager or the Microsoft Exchange Information Store service, or both.
ID no: c1041724
Exchange System Manager
Additionally, the following events are logged in the Application log:

Event ID: 1159
Event Type: Error
Event Source: MSExchangeIS
Event Category: General
Description: Database error 0xfffffdf9 occurred in function JTAB_BASE::EcEscrowUpdate while accessing the database "First Storage Group\Mailbox Store (SERVER)".

Event ID: 9518
Event Type: Error
Event Source: MSExchangeIS
Event Category: General
Description: Error 0xfffffddc starting Storage Group Path_of_Storage_Group on the Microsoft Exchange Information Store. Storage Group - Initialization of Jet failed.

Symptom 2

In the original release version of Exchange Server 2003 or in versions of Exchange 2000 Server that are not running the August 2004 Exchange 2000 Server post-Service Pack 3 update rollup, users who have mailboxes in a particular storage group start to experience logon failures or other failures.

This problem occurs when the users connect to their Exchange 2000 Server mailboxes or to their Exchange Server 2003 mailboxes. Although the store databases are still mounted, these databases become inaccessible.

Additionally, an event that resembles the following event is logged in the Application log:

Event Type: Error
Event Source: MSExchangeIS Mailbox
Event Category: Logons
Event ID: 1022
Description: Logon Failure on database Path_of_Database.
Error: -519

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Cause

This problem may occur if Exchange Server has used all the transaction logs that are available to a storage group.

Exchange uses transaction log files that are numbered sequentially. The first file name in the transaction log file sequence is "E nn 00001.log." The file names increase sequentially to "E nn ffff0.log."

Note In this log file name, nn is the number of the storage group.

The maximum number of transaction log files that can be generated in a single sequence is 1,048,560 (0xFFFF0).

When the last transaction log is filled, the Microsoft Jet database engine returns error "-519 (JET_errLogSequenceEnd)" to the store. This error causes the symptoms in the different versions of Exchange that are mentioned in the "Symptoms" section.

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Workaround

To work aroun this issue, you can use the Microsoft Exchange Troubleshooting Assistant tool because it automates the process of verifying the health of your databases and resetting the transaction log sequence.

To download the Microsoft Exchange Troubleshooting Assistant, visit the following Web site:
http://www.microsoft.com/downloads/details.aspx?familyid=4BDC1D6B-DE34-4F1C-AEBA-FED1256CAF9A&displaylang=en
After that, you can follow the instructions in the following Web pages to reset the transaction log sequence:
http://technet.microsoft.com/en-us/library/aa998611(EXCHG.80).aspx
http://technet.microsoft.com/en-us/library/bb266925(EXCHG.80).aspx

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

Hotfix to help identify the problem

Microsoft has created a hotfix for Exchange 2000 Server to help identify the problem. After you apply this hotfix, the store databases dismount when the Microsoft Jet database engine returns the "-519 (JET_errLogSequenceEnd)" error. This behavior helps Exchange Server administrators quickly identify the problem storage group.

This hotfix is also included in the following items:
  • The August 2004 Exchange 2000 Server post-Service Pack 3 update rollup
  • Exchange Server 2003 SP1
After you apply the hotfix, the update rollup, or the service pack, you still must manually reset the log files. To do this, see the steps in the "Workaround" section.

Hotfix information

Prerequisites
You must install Exchange 2000 Server Service Pack 3 (SP3) before you apply the hotfix.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
301378 How to obtain the latest Exchange 2000 Server service pack
Restart information
You do not have to restart the computer after you apply the hotfix. However, the Microsoft Exchange Information Store service and all dependent services will be stopped and then restarted.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Cdoex.dll6.0.6527.03,915,77627-Oct-200314:47x86
Davex.dll6.0.6527.0851,96827-Oct-200314:42x86
Davexpc.dll6.0.6527.053,24827-Oct-200314:42x86
Drviis.dll6.0.6527.0131,07227-Oct-200314:38x86
Dsaccess.dll6.0.6527.0577,53627-Oct-200314:38x86
Dscmsg.dll6.0.6527.0184,32027-Oct-200313:48x86
Emsmdb32.dll6.0.6527.0962,56027-Oct-200313:48x86
Ese.dll6.0.6527.02,179,07227-Oct-200314:41x86
Eseperf.dll6.0.6527.040,96027-Oct-200314:41x86
Eseperf.hxxNot applicable6,99108-Sep-200311:48Not applicable
Eseperf.iniNot applicable391,63427-Oct-200314:41Not applicable
Excdo.dll6.0.6527.03,575,80827-Oct-200314:47x86
Eximap4.dll6.0.6527.090,11227-Oct-200314:37x86
Exmime.dll6.0.6527.0262,14427-Oct-200314:39x86
Exnntp.dll6.0.6527.0176,12827-Oct-200313:27x86
Exodbesh.dll6.0.6527.0143,36027-Oct-200314:42x86
Exodbpc.dll6.0.6527.057,34427-Oct-200314:42x86
Exodbprx.dll6.0.6527.0200,70427-Oct-200314:42x86
Exoledb.dll6.0.6527.02,179,07227-Oct-200314:42x86
Exosal.dll6.0.6527.081,92027-Oct-200314:36x86
Expop3.dll6.0.6527.032,76827-Oct-200314:38x86
Exproto.dll6.0.6527.032,76827-Oct-200314:38x86
Exprox.dll6.0.6527.0307,20027-Oct-200314:42x86
Exschema.exe6.0.6527.0143,36027-Oct-200313:51x86
Exsmtp.dll6.0.6527.0315,39227-Oct-200314:42x86
Exwform.dll6.0.6527.0675,84027-Oct-200313:53x86
Exwin32.dll6.0.6527.0180,22427-Oct-200313:28x86
Febecfg.dll6.0.6527.040,96027-Oct-200313:51x86
Iisif.dll6.0.6527.032,76827-Oct-200314:38x86
Iisproto.dll6.0.6527.0135,16827-Oct-200314:39x86
Imap4be.dll6.0.6527.061,44027-Oct-200314:39x86
Imap4evt.dll6.0.6527.0319,48827-Oct-200313:54x86
Imap4fe.dll6.0.6527.0126,97627-Oct-200313:52x86
Imap4svc.dll6.0.6527.0126,97627-Oct-200314:38x86
Jcb.dll6.0.6527.040,96027-Oct-200314:39x86
Mdbevent.dll6.0.6527.049,15227-Oct-200313:28x86
Mdbmsg.dll6.0.6527.02,285,56827-Oct-200313:45x86
Mdbrole.dll6.0.6527.032,76827-Oct-200313:30x86
Mdbsz.dll6.0.6527.0909,31227-Oct-200313:48x86
Mdbtask.dll6.0.6527.024,57627-Oct-200314:39x86
Nntpex.dll6.0.6527.0151,55227-Oct-200313:27x86
Peexch50.dll6.0.6527.094,20827-Oct-200314:34x86
Phatcat.dll6.0.6527.0397,31227-Oct-200314:36x86
Pop3be.dll6.0.6527.036,86427-Oct-200314:38x86
Pop3evt.dll6.0.6527.0303,10427-Oct-200313:54x86
Pop3fe.dll6.0.6527.024,57627-Oct-200313:53x86
Pop3svc.dll6.0.6527.073,72827-Oct-200314:36x86
Protomsg.dll6.0.6527.0163,84027-Oct-200313:54x86
Reapi.dll6.0.6527.0532,48027-Oct-200314:39x86
Resvc.dll6.0.6527.0311,29627-Oct-200314:42x86
Store.exe6.0.6527.04,661,24827-Oct-200314:37x86
Wmtemplates.dll6.0.6527.03,735,55227-Oct-200313:53x86

Hotfix to configure Exchange to log an event before it reaches the end of the log file sequence

To help prevent this problem from occurring, you can apply the hotfix that is described in the following Microsoft Knowledge Base article:
896001 An event is not logged in the Application log before the last available transaction log in the sequence is used in Exchange 2000 Server
This hotfix (hotfix 896001) is included in Exchange Server 2003 SP2.

This hotfix (hotfix 896001) is included in Exchange Server 2003 SP1. After you apply hotfix 896001, Exchange Server 2003 SP1, or Exchange Server 2003 SP2, an event that resembles the following event is logged in the Application log when the last available transaction log in the sequence becomes available:
Event Type: Warning
Event Source: ESE
Event Category: Logging/Recovery
Event ID: 514
Description: Information Store (2748) SG2: Log sequence numbers for this instance have almost been completely consumed. To begin renumbering from generation 1, the instance must be shutdown cleanly and all log files must be deleted. Backups will be invalidated.
Issues that occur after you apply hotfix 896001, install Exchange Server 2003 SP1, or install Exchange Server 2003 SP2
You apply hotfix 896001 for Exchange 2000 Server, or you install Exchange Server 2003 SP1 or Exchange Server 2003 SP2. You use the available transaction log files. Then you try to mount the stores without performing the steps that are described in the "Workaround" section.

When you do this, events that are similar to the following events may be logged in the Application log:

Event Type: Error
Event Source: MSExchangeIS
Event Category: General
Event ID: 1159
Description: Database error 0xfffffdf9 occurred in function JTAB_BASE::EcEscrowUpdate while accessing the database "First Storage Group\Mailbox Store (SERVER)".

Event Type: Error
Event Source: MSExchangeIS
Event Category: General
Event ID: 9518
Description: Error 0xfffffddc starting Storage Group Path_of_Storage_Group on the Microsoft Exchange Information Store.
Storage Group - Initialization of Jet failed.

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References

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
870540 Availability of the August 2004 Exchange 2000 Server post-Service Pack 3 update rollup
For more information about the terminology that is used to describe Microsoft product updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB830408, kbbug, kbexchange2000presp4fix, kbfix, kbqfe, kbexchange2003sp1fix, kbhotfixserver

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Article Info
Article ID : 830408
Revision : 15
Created on : 10/4/2012
Published on : 10/4/2012
Exists online : False
Views : 281