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Your ISA Server 2000 server stops responding to SSL CONNECT requests


View products that this article applies to.

Symptoms

After a while, the Microsoft Internet Security and Acceleration (ISA) Server Web Proxy service may stop responding to Secure Sockets Layer (SSL) CONNECT requests from outbound clients. You have to restart the Web Proxy service to resolve the problem.

If you use System Monitor to view the Private Bytes counter and the Handle Count counter from the Process performance object for the W3proxy.exe process, you see that the values of these counters increase over time.

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Cause

This problem may occur if the downstream ISA Server server is passing information upstream to another Web Proxy server, and the following steps occur:
  1. A Web Proxy client sends an SSL CONNECT request to open an SSL tunnel through the downstream and upstream proxies to a destination server.
  2. The Web Proxy client then receives a "200 Connection Established" response from the downstream Web Proxy server. This response indicates that the SSL tunnel was established successfully.
  3. The client then disconnects the SSL tunnel before any data is exchanged with the server.
Under these conditions, the connection from the downstream ISA server to the upstream proxy server may be left open, and other system resources may be consumed and not released.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To install this hotfix, you must have ISA Server 2000 Service Pack 2 (SP2) installed on your computer.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size     File name
   ------------------------------------------------------
   14-Jul-2004  17:41  3.0.1200.403  401,400  W3proxy.exe
This hotfix is also available for the French, German, Spanish, and Japanese versions of ISA Server 2000.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

This hotfix includes the hotfix that is mentioned in the following Microsoft Knowledge Base article:
821098� Content cache issues on downstream ISA Server computer

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Keywords: KB830221, kbbug, kbfix, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 830221
Revision : 6
Created on : 6/14/2007
Published on : 6/14/2007
Exists online : False
Views : 311