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Mouse pointer movement is not smooth if you use Microsoft Terminal Services Advanced Client 5.1 or later


View products that this article applies to.

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows registry

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Symptoms

On a client computer, if you use Microsoft Terminal Services Advanced Client 5.1 or later to connect to a terminal server (that is, a server that has Terminal Server enabled), you may notice that the mouse pointer movement is not smooth; it may move in small jerks. This is most noticeable when you use a painting program, such as Microsoft Paint, or the drawing tools in a Microsoft Office program.

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Cause

This behavior occurs because the mouse movement update interval is 120 milliseconds in Terminal Services Advanced Client 5.1 or later and the value cannot be adjusted to a smaller interval.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix. However, once you install the hotfix, you must add a registry value as described in the "More Information" section.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
   Date         Time   Version     Size     File name       Platform
   -----------------------------------------------------------------
   07-Oct-2003  20:29  6.0.2600.0  498,176  Tswebsetup.exe  x86

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More information

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.To enable this hotfix, follow these steps:
  1. On the Terminal Server client computer, start Registry Editor, and then locate the following registry subkey:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Terminal Server Client
  2. Right-click Terminal Server Client, and then point to New.
  3. Click DWORD, and then type Min Send Interval. Double-click this entry, and then set the value to 10.
  4. Quit Registry Editor, and then restart the computer.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbhotfixserver, kbqfe, kbbug, kbfix, kbqfe, kbwinserv2003presp1fix, kbautohotfix, KB830209

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Article Info
Article ID : 830209
Revision : 13
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 389