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Dsget.exe tool output may fail when used with another tool or script in Windows Server 2003 or in Windows XP


View products that this article applies to.

Symptoms

Consider this scenario: You use the Dsget.exe tool to write certain Active Directory directory service objects to a text file on a computer that is running Microsoft Windows Server 2003 or Microsoft Windows XP. When you use this text file with another tool or script, such as with the Ldifde.exe tool or with the Dsquery.exe tool, the tool or script may fail.

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Cause

This problem occurs because the output from the Dsget.exe tool has trailing spaces that are displayed after a list of group names, and the output does not include the "\" character.

The text file that is generated by the Dsget.exe tool may include one or more of the following Active Directory objects:
  • Attributes of a computer
  • Attributes of a contact
  • Attributes of a group
  • Attributes of an organizational unit
  • Attributes of a server
  • Attributes of a user

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Resolution

Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
No prerequisites are required.
Restart requirement
You do not have to restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size  File name      Platform
   -----------------------------------------------------------------
   23-Oct-2003  01:15  5.2.3790.83   29,696  Wmspatcha.dll  x86
   23-Oct-2003  00:15  5.2.3790.95  144,384  Dsadd.exe      x86
   23-Oct-2003  00:15  5.2.3790.95  218,624  Dsget.exe      x86
   23-Oct-2003  00:15  5.2.3790.95  179,200  Dsmod.exe      x86
   23-Oct-2003  00:15  5.2.3790.95   33,280  Dsmove.exe     x86
   23-Oct-2003  00:15  5.2.3790.95  224,768  Dsquery.exe    x86
   23-Oct-2003  00:15  5.2.3790.95   37,376  Dsrm.exe       x86
   23-Oct-2003  00:49  5.2.3790.95  238,080  Dsadd.exe      IA-64
   23-Oct-2003  00:49  5.2.3790.95  332,288  Dsget.exe      IA-64
   23-Oct-2003  00:49  5.2.3790.95  265,216  Dsmod.exe      IA-64
   23-Oct-2003  00:49  5.2.3790.95   79,360  Dsmove.exe     IA-64
   23-Oct-2003  00:49  5.2.3790.95  341,504  Dsquery.exe    IA-64
   23-Oct-2003  00:49  5.2.3790.95   90,112  Dsrm.exe       IA-64

Windows XP

Service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
No prerequisites are required.
Restart requirement
You do not have to restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size  File name     Platform
   ----------------------------------------------------------------
   25-Oct-2003  10:58  5.2.3790.97  238,080  Dsadd.exe     IA-64
   25-Oct-2003  10:58  5.2.3790.97  332,288  Dsget.exe     IA-64
   25-Oct-2003  10:58  5.2.3790.97  265,216  Dsmod.exe     IA-64
   25-Oct-2003  10:58  5.2.3790.97   79,360  Dsmove.exe    IA-64
   25-Oct-2003  10:58  5.2.3790.97  341,504  Dsquery.exe   IA-64
   25-Oct-2003  10:58  5.2.3790.97   90,112  Dsrm.exe      IA-64
   22-Oct-2003  23:49  5.2.3790.95  144,384  Wdsadd.exe    x86
   22-Oct-2003  23:49  5.2.3790.95  218,624  Wdsget.exe    x86
   22-Oct-2003  23:49  5.2.3790.95  179,200  Wdsmod.exe    x86
   22-Oct-2003  23:49  5.2.3790.95   33,280  Wdsmove.exe   x86
   22-Oct-2003  23:49  5.2.3790.95  224,768  Wdsquery.exe  x86
   22-Oct-2003  23:49  5.2.3790.95   37,376  Wdsrm.exe     x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Windows XP This problem was first corrected in Microsoft Windows XP Service Pack 2.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbhotfixserver, kbwinxpsp2fix, kbwinservds, kbactivedirectory, kbwinserv2003presp1fix, kbwinxppresp2fix, kbbug, kbfix, kbqfe, kbqfe, KB830170

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Article Info
Article ID : 830170
Revision : 11
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 337