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XCLN: Event ID 5004 Is Logged, and You Cannot Generate an Offline Address Book


View products that this article applies to.

Symptoms

When you try to generate an offline Address Book on your Microsoft Exchange Server 5.5 computer, the offline Address Book may not be created, and an event that is similar to the following may be logged in the application log:

Source: MSExchangeSA
Event ID: 5004
Category: General
Description: Generation of the offline Address Book is complete. Result: An error occurred.

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Cause

This problem may occur when the Global Address List grows to a size that requires more than 1 megabyte (MB) of memory to generate the offline Address Book.

When you try to generate an offline Address Book, the stack allocates memory to the offline Address Book process for the list of recipients that the Global Address List contains. By default, the stack can allocate up to 1 MB of memory when the stack generates the offline Address Book. If more than 1 MB is requested by the offline Address Book process, the stack fulfills the request only if there is sufficient free space immediately adjacent to the original 1 MB of memory. Computers that have more memory are more likely to have free space immediately adjacent to the stack. Therefore, there is a greater chance that the offline Address Book will be generated. If there is not sufficient free space immediately adjacent to the original 1 MB of memory, the stack cannot generate the offline Address Book, and event 5004 is logged in the application log.

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Resolution

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time     Size       File name
------------------------------------------------------------------
15-Nov-2003  04:14    1,186,360  Exchange5.5-kb830116-x86-enu.exe

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

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More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the Standard Terminology That Is Used to Describe Microsoft Software Updates

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Keywords: KB830116, kbbug, kbfix, kbqfe, kbexchange550presp5fix, kbqfe, kbhotfixserver

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Article Info
Article ID : 830116
Revision : 5
Created on : 10/26/2006
Published on : 10/26/2006
Exists online : False
Views : 269