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BUG: You receive an "E_INVALIDARG" exception of type 0x80070057 when a ServicedComponent object is activated


View products that this article applies to.

Symptoms

When you activate a managed class that is derived from a System.EnterpriseServices.ServicedComponent (ServicedComponent) object, you may receive an "E_INVALIDARG" exception of type 0x80070057.

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Cause

This problem occurs when you activate a managed class that is derived from a ServicedComponent object. When a Microsoft Component Object Model (COM)-based single threaded apartment (STA) thread terminates, the references that the thread contained to COM objects are de-referenced and revoked. When new objects are activated, the managed common language runtime starts its asynchronous finalization routine. References may be maintained to the revoked STA COM-based objects. When the common language runtime tries to remove references to these STA COM-based objects, you may receive an "E_INVALIDARG" exception because the objects have already been revoked.

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Resolution

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft .NET Developer Platform service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size     File name
   ---------------------------------------------------------------------------------
   24-Sep-2003  16:55  1.0.3705.460  212,992  system_enterpriseservices.dll
   24-Sep-2003  02:26  1.0.3705.460   48,640  system_enterpriseservices_thunk.dll

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Status

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

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Properties

Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

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Keywords: KB829393, kbqfe, kbwinserv2003presp1fix, kbfix, kbbug

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Article Info
Article ID : 829393
Revision : 4
Created on : 10/5/2005
Published on : 10/5/2005
Exists online : False
Views : 456