Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

An access violation error occurs if your Terminal Services information is corrupted


View products that this article applies to.

Symptoms

When you run a Terminal Services administrative utility, such as Tsprof.exe, Mmc.exe, or Usrmgr.exe, the utility may generate an access violation error and quit unexpectedly when it manages certain user accounts.

When you run any program that uses the API functions of WTSSetUserConfig or WTSQueryUserConfig to set or to retrieve user information, the utility may generate an access violation error and quit unexpectedly when it manages certain user accounts.

When you make a Remote Desktop connection and then try to log on with a certain user account, the Remote Desktop connection may suddenly close. If the Remote Desktop-based logon attempt was to a Microsoft Windows XP-based computer or to a Microsoft Windows Server 2003-based console computer, the Remote Desktop computer will perform a bugcheck after Winlogon unexpectedly quits. Depending on the configuration, the Remote Desktop computer may restart.

One or more of the following events may be written to the event log:

Event ID 1004
Source Application Error
Reporting queued error: faulting application mmc.exe, version 5.2.3790.0, faulting module tsuserex.dll, version 5.2.3790.0, fault address 0x0000c3a9.

Event ID 1004
Source Application Error
Reporting queued error: faulting application mmc.exe, version 5.2.3790.0, faulting module tsuserex.dll, version 5.2.3790.0, fault address 0x0000c3a9.

Event ID 1004
Source Application Error
Reporting queued error: faulting application mmc.exe, version 5.2.3790.0, faulting module tsuserex.dll, version 5.2.3790.0, fault address 0x0000c3a9.

Event ID 1004
Source Application Error
Faulting application , version 0.0.0.0, faulting module regapi.dll, version 5.2.3790.0, fault address 0x00002c4d.

Event ID 1004
Source Application Error
Reporting queued error: faulting application winlogon.exe, version 0.0.0.0, faulting module regapi.dll, version 5.2.3790.0, fault address 0x00002c4d.

Event ID 1001
Source Application Error
Fault bucket 62739595.

Event ID 1001
Source Application Error
Fault bucket 45054588

↑ Back to the top


Cause

This problem may occur when corrupted user data is encountered.

↑ Back to the top


Resolution

Windows Server 2003 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, 32-bit editions

   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   19-Aug-2004  23:41  5.2.3790.202       50,176  Regapi.dll
   19-Aug-2004  23:41  5.2.3790.202       81,920  Tsuserex.dll

Windows Server 2003, 64-bit editions

   Date         Time   Version            Size    File name     Platform
   ---------------------------------------------------------------------
   19-Aug-2004  21:37  5.2.3790.202      129,536  Regapi.dll     IA-64
   19-Aug-2004  21:37  5.2.3790.202      223,744  Tsuserex.dll   IA-64
   19-Aug-2004  21:41  5.2.3790.202       50,176  Wregapi.dll    x86
   19-Aug-2004  21:41  5.2.3790.202       81,920  Wtsuserex.dll  x86

Windows XP service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Windows XP hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP, 32-bit editions

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   10-Sep-2003  18:30  5.1.2600.1254      32,768  Cfgbkend.dll
   10-Sep-2003  18:30  5.1.2600.1254      30,720  Pchsvc.dll
   10-Sep-2003  18:30  5.1.2600.1254      33,280  Racpldlg.dll
   10-Sep-2003  18:30  5.1.2600.1267      44,544  Regapi.dll
   10-Sep-2003  18:30  5.1.2600.1254      41,472  Safrslv.dll
   02-Aug-2003  07:45  5.1.2600.1254     129,536  Sessmgr.exe
   10-Sep-2003  18:30  5.1.2600.1254     200,192  Termsrv.dll
   10-Sep-2003  18:30  5.1.2600.1254      88,064  Tscfgwmi.dll

Windows XP, 64-bit editions

   Date         Time   Version            Size    File name     Platform
   ----------------------------------------------------------------------
   10-Sep-2003  17:38  5.1.2600.1254     104,448  Cfgbkend.dll  IA-64
   10-Sep-2003  17:38  5.1.2600.1254     110,080  Pchsvc.dll    IA-64
   10-Sep-2003  17:38  5.1.2600.1254      90,112  Racpldlg.dll  IA-64
   10-Sep-2003  17:38  5.1.2600.1267     127,488  Regapi.dll    IA-64
   10-Sep-2003  17:38  5.1.2600.1254     111,616  Safrslv.dll   IA-64
   02-Aug-2003  08:44  5.1.2600.1254     419,328  Sessmgr.exe   IA-64
   10-Sep-2003  17:38  5.1.2600.1254     622,592  Termsrv.dll   IA-64
   10-Sep-2003  17:38  5.1.2600.1254     326,144  Tscfgwmi.dll  IA-64
   10-Sep-2003  18:30  5.1.2600.1267      44,544  Wregapi.dll   x86

Windows 2000

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size    File name
   ------------------------------------------------------
   07-Jan-2004  20:44  5.0.2195.6889  36,624  Regapi.dll

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Windows XP

This problem was first corrected in Microsoft Windows XP Service Pack 2.

↑ Back to the top


More information

The hotfix that is described in this article does not correct the corrupted data. The hotfix protects the code from causing the process to quit unexpectedly with an access violation error.

After you apply this hotfix, you may be able to log on to a Windows 2000-based or a Windows XP-based computer by using Remote Desktop without errors. However, you may still receive an error message when you change the properties of the user account or when you log on by using that account.

If you use Microsoft Management Console (MMC) to edit or view the user properties, you may receive an error message that is similar to the following:
Terminal Services Properties
Could not load Terminal Services properties for this user because: The parameter is incorrect.
Or, When you try to log on to a Windows Server 2003-based computer by using a Remote Desktop connection, you may receive an error message that is similar to the following:
Logon Message
The system could not log you on due to the following error: The parameter is incorrect.
Please try again or consult your system administrator
To correct the Terminal Services user data corruption, follow these steps:
  1. Create a text file with the following lines of text, where username is the name of the user account with the corrupted information and where domain is your domain name.
    dn: CN=username,CN=Users,DC=domain,DC=com
    changetype: modify
    delete: userParameters
  2. Name the file "Users.txt."
  3. At a command prompt, type the following command to run the file:
    Ldifde –I –f users.txt
    Running this command will also clear the properties and resolve the issue on an Active Directory domain.

    Note Clearing the userParameters attribute in the user account may affect other programs. If program-specific information is stored there, it will have to be repopulated. For example, programs that may be affected are FPNW, RAS, and all Terminal Services-specific user information.

↑ Back to the top


References

For additional information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbfix, kbqfe, kbwinxppresp2fix, kbwinxpsp2fix, kbqfe, kbhotfixserver, KB828664, kbwinxpsp2fix, kbfix, kbqfe, kbwinxppresp2fix, kbbug, kbqfe, kbhotfixserver, kbautohotfix, kbbug, KB828664

↑ Back to the top

Article Info
Article ID : 828664
Revision : 13
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 370