Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Public folder replication does not occur, and event ID 3020 is logged on a computer that is running Exchange 2000 or Exchange 2003


View products that this article applies to.

Symptoms

Public folder replication does not occur on a computer that is running Microsoft Exchange 2000 Server or Microsoft Exchange Server 2003. Outgoing replication events that are similar to the following are logged in the application event log:

Event Type: Information
Event Source: MSExchangeIS Public Store
Event Category: Replication Outgoing Messages
Event ID: 3020
Computer: servername
Description: An outgoing replication message was issued.

Type: 0x4
Message ID: 1-931017
Folder: (1-1934F1) IPM_SUBTREE\Foldername

Database "First Storage Group\Public Information Store (servername)". CN min: 1-19CDFA, CN max: 1-19CDFA
Message IDs: 1
1: 1-19CBEE, 1-19CDFA
--- : Post on servername : 8/26/2003 9:04:47 PM

MIDSET Deleted: {0}

Other outgoing replication events that may be recorded include the following event IDs:
  • 3014
  • 3016
  • 3017
  • 3018
  • 3019
  • 3021
If you review the message tracking logs on the server where the event that is described is logged, you may find no record that this message was sent. Additionally, other computers in the same Exchange organization do not log an incoming replication message event that corresponds to this message.

If you restart the Microsoft Exchange Information Store service on the computer, replication messages may be sent for a brief period of time.

↑ Back to the top


Cause

This problem may occur on Exchange computers that have virus scanning enabled when the scanner is using the Background Scanning mode or the Proactive Scanning mode.

↑ Back to the top


Resolution

Exchange 2000

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Component: MDB\REPLICATION

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version            Size    File name
--------------------------------------------------------------
15-Oct-2003  14:31  6.0.6521.0      3,915,776  Cdoex.dll        
15-Oct-2003  14:25  6.0.6521.0        851,968  Davex.dll        
15-Oct-2003  14:25  6.0.6521.0         53,248  Davexpc.dll      
15-Oct-2003  14:22  6.0.6521.0        131,072  Drviis.dll       
15-Oct-2003  14:22  6.0.6521.0        577,536  Dsaccess.dll     
15-Oct-2003  13:33  6.0.6521.0        184,320  Dscmsg.dll       
15-Oct-2003  13:33  6.0.6521.0        962,560  Emsmdb32.dll     
15-Oct-2003  14:25  6.0.6521.0      2,179,072  Ese.dll          
15-Oct-2003  14:25  6.0.6521.0         40,960  Eseperf.dll      
08-Sep-2003  17:18                      6,991  Eseperf.hxx
15-Oct-2003  14:25                    391,634  Eseperf.ini
15-Oct-2003  14:31  6.0.6521.0      3,575,808  Excdo.dll        
15-Oct-2003  14:22  6.0.6521.0        262,144  Exmime.dll       
15-Oct-2003  14:25  6.0.6521.0        143,360  Exodbesh.dll     
15-Oct-2003  14:25  6.0.6521.0         57,344  Exodbpc.dll      
15-Oct-2003  14:25  6.0.6521.0        200,704  Exodbprx.dll     
15-Oct-2003  14:25  6.0.6521.0      2,179,072  Exoledb.dll      
15-Oct-2003  14:20  6.0.6521.0         81,920  Exosal.dll       
15-Oct-2003  14:25  6.0.6521.0        307,200  Exprox.dll       
15-Oct-2003  13:36  6.0.6521.0        143,360  Exschema.exe     
15-Oct-2003  14:25  6.0.6521.0        315,392  Exsmtp.dll       
15-Oct-2003  13:38  6.0.6521.0        675,840  Exwform.dll      
15-Oct-2003  14:23  6.0.6521.0         40,960  Jcb.dll          
15-Oct-2003  13:18  6.0.6521.0        745,472  Mapi32.dll       
15-Oct-2003  13:13  6.0.6521.0         49,152  Mdbevent.dll     
15-Oct-2003  13:30  6.0.6521.0      2,285,568  Mdbmsg.dll       
15-Oct-2003  13:15  6.0.6521.0         32,768  Mdbrole.dll      
15-Oct-2003  14:23  6.0.6521.0         24,576  Mdbtask.dll      
15-Oct-2003  14:19  6.0.6521.0         94,208  Peexch50.dll     
15-Oct-2003  14:20  6.0.6521.0        397,312  Phatcat.dll      
15-Oct-2003  14:23  6.0.6521.0        532,480  Reapi.dll        
15-Oct-2003  14:25  6.0.6521.0        311,296  Resvc.dll        
15-Oct-2003  14:21  6.0.6521.0      4,657,152  Store.exe        
15-Oct-2003  13:38  6.0.6521.0      3,735,552  Wmtemplates.dll
Note Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3 (SP3). For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
301378 How to obtain the latest Exchange 2000 Server service pack

Exchange Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   03-Oct-2003  01:06  6.5.6980.32        49,152  Mdbevent.dll     
   03-Oct-2003  01:43  6.5.6980.32     3,186,176  Mdbmsg.dll       
   03-Oct-2003  01:08  6.5.6980.32        24,064  Mdbrole.dll      
   03-Oct-2003  05:11  6.5.6980.32        13,312  Mdbtask.dll      
   03-Oct-2003  05:10  6.5.6980.32     5,038,592  Store.exe         

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

↑ Back to the top


Keywords: KB828420, kbbug, kbexchange2000presp4fix, kbfix, kbqfe, kbhotfixserver, kbautohotfix

↑ Back to the top

Article Info
Article ID : 828420
Revision : 10
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 295