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You Cannot Export a Commerce Server Catalog to XML


View products that this article applies to.

Symptoms

When you try to export a Microsoft Commerce Server 2002 catalog to XML, the resulting file cannot be imported, and you receive the following error message:
"The XML file path/filename contains an error at line. " "A Name contained an invalid character."
If you validate the XML catalog by using Microsoft Visual Studio .NET 2003, you receive the following error message:
"The '(' character, hexadecimal value 0x28, cannot begin a name. Line #, Position #"

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Cause

This problem occurs because the Commerce Server export was not encoding the following special characters:
  • The range 0x0021 � 0x002F includes ! � # $ % & � ( ) * + , - . /
  • The range 0x03A � 0x0040 includes : ; < = > ? @
  • The range 0x007B � 0x007E includes { | } ~
  • The range 0x005B � 0x005E [ \ ] ^

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Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   15-Sep-2003  23:52  4.5.3332.0        954,468  Catalog.dll

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

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Keywords: KB828345, kbbug, kbfix, kbqfe, kbhotfixserver, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 828345
Revision : 6
Created on : 11/15/2007
Published on : 11/15/2007
Exists online : False
Views : 353