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When you convert BASIC disks to dynamic disks, the operation takes a long time


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Symptoms

When you try to convert many BASIC disks to DYNAMIC disks on a Microsoft Windows Server 2003-based computer, the disks may take a long time to convert. For example, the conversion may take as long as two minutes for each device. Additionally, the Disk Management Microsoft Management Console (MMC) snap-in may stop responding. You may have to restart the Disk Management snap-in to access the converted devices.

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Cause

This problem may occur if logging is enabled for the Virtual Disk service (VDS). Additionally, the process may be slower in Windows Server 2003 because disks are converted one at a time. This change is required because of the introduction of the Virtual Disk service in Windows Server 2003.

Note In Microsoft Windows 2000 Server, disk conversions are handled in parallel processes.

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Status

This behavior is by design.

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More information

To turn off logging for the VDS, follow these steps. Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Click Start, and then click Run.
  2. Type regedit, and then click OK.
  3. Locate the following registry key:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Vds
  4. Right-click the DebugLog value, and then click Delete.
  5. Close Registry Editor.
  6. Click Start, point to Administrative Tools, and then click Services.
  7. Stop and then start the VDS.
The VDS implements a single, uniform interface for managing disks. Each hardware vendor writes a VDS provider that translates general purpose VDS application programming interfaces (APIs) into specific instructions for that hardware vendor's hardware. With this abstraction layer that is provided by the VDS, Windows Server 2003 offers a more robust set of solutions, including greater flexibility for making long-term investment decisions about storage area networks (SANs) and about other storage options.

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References

For additional information about Windows Server 2003 file services, click the following article number to view the article in the Microsoft Knowledge Base:
818703 White Paper: Technical Overview of Windows Server 2003 File Services
For additional informationVirtual Disk Service logging, click the following article number to view the article in the Microsoft Knowledge Base:
842011 How to turn on logging for the VDS in Windows Server 2003

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Keywords: KB828220, kbbug, kbperformance, kbusage

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Article Info
Article ID : 828220
Revision : 4
Created on : 10/30/2006
Published on : 10/30/2006
Exists online : False
Views : 164