Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: You Cannot Rename a File After You Upload the File to an FTP Server


View products that this article applies to.

Symptoms

If you upload a large file to an FTP server, and you try to rename the file immediately, you may receive the following error message:
550 The process cannot access the file because it is being used by another process.
The following entries are logged in the Microsoft Internet Information Services (IIS) log:
08:19:47 65.53.232.91 [4]RNFR myfile.zip 350 0 08:19:47 65.53.232.91 [4]RNTO myfile.zip.ftp 550 32
08:19:47 65.53.232.91 [4]QUIT - 550 0
08:19:47 65.53.232.91 [4]created /myfile.zip 226 0

↑ Back to the top


Cause

This problem occurs because the first step in the rename process, RNFR (Rename From), for the Myfile.zip file starts before the put (or create) action of the Myfile.zip file is complete.

↑ Back to the top


Resolution

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
  Date         Time   Version            Size    File name
   --------------------------------------------------------------
   05-Sep-2003  09:27  6.0.3790.82       119,808  Ftpsvc2.dll 

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

↑ Back to the top


Keywords: kbautohotfix, kbhotfixserver, kbhotfixserver, kbqfe, kbbug, kbfix, kbqfe, kbwinserv2003presp1fix, kbqfe, KB828086

↑ Back to the top

Article Info
Article ID : 828086
Revision : 15
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 330