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PRB: Cannot Install Commerce Server 2002 Developer Edition on Windows XP


View products that this article applies to.

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows Registry

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Symptoms

When you try to install Microsoft Commerce Server 2002 Developer Edition on a computer that is running Microsoft Windows XP, the installation fails.

During setup, service accounts are configured. Each Service Account has a user name, a password, and a domain name. After this operation, you receive the following error message:
Error: Invalid Service Logon Information. The specified service logon "Domain\Username" is invalid.

Error code: Logon failure: unknown user name or bad password.

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Cause

This problem occurs because the computer is not a part of a domain (in a peer-to-peer network). Commerce Server 2002 Setup uses Security Support Provider Interface (SSPI) to do a network-style logon by using the provided user credentials. This type of validation does not require the current user to have any special rights. Also, this type of validation works on all versions of Microsoft Windows. However, on Windows XP, the ForceGuest registry value is set to 1.

On a computer that is running Windows XP, and that is a member of a workgroup:
  • If ForceGuest is enabled (set to 1), SSPI always tries to log on by using the Guest user account:
    • If the Guest account is enabled, an SSPI logon will succeed as Guest for any user credentials.
    • If the Guest account is disabled, an SSPI logon will fail regardless of whether you provide valid credentials.
    This is the default behavior on Windows XP in a peer-to-peer network.
  • If ForceGuest is disabled (set to 0), SSPI logs on as the specified user.

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Resolution

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this problem, set the ForceGuest registry value to 0 in the following registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

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Status

This behavior is by design.

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References

For additional information about this issue, click the following article number to view the article in the Microsoft Knowledge Base:
180548� HOWTO: Validate User Credentials on Microsoft Operating Systems
290403� How to Set Security in Windows XP Professional That Is Installed in a Workgroup

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Keywords: KB827918, kbprb

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Article Info
Article ID : 827918
Revision : 4
Created on : 10/2/2003
Published on : 10/2/2003
Exists online : False
Views : 339