Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Terminal Server Remote Session Unexpectedly Runs in Install Mode


View products that this article applies to.

Symptoms

When a remote client computer connects to a Microsoft Windows Server 2003-based terminal server, and the locale settings (in the Regional and Language Options tool in Control Panel) on the remote client are different from the locale settings on the terminal server, the terminal server session runs in install mode.

↑ Back to the top


Cause

During logon, the session is set to install mode before it runs certain automated tasks in case these automated tasks are part of an installation. After these tasks complete, the session is reset to execute mode. However, if the Ctfmon.exe program is one of the automated tasks, Ctfmon.exe does not exit, and therefore the session is not reset to execute mode. If you end the Ctfmon process, the session is then reset to execute mode, but this results in the loss of Ctfmon functionality.

↑ Back to the top


Resolution

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Windows Server 2003.

Restart Requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   13-Aug-2003  00:37  5.2.3790.77        24,064  Userinit.exe  

↑ Back to the top


More information

For additional information about Ctfmon, click the following article number to view the article in the Microsoft Knowledge Base:
282599� OFFXP: What Is CTFMON and What Does It Do?

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

↑ Back to the top


Keywords: kbhotfixserver, kbqfe, kbbug, kbfix, kbqfe, kbwinserv2003presp1fix, kbautohotfix, KB826821

↑ Back to the top

Article Info
Article ID : 826821
Revision : 17
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 382