Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Certificates other than logon certificates on a smart card are not propagated to the local certificate store of the user in Windows Server 2003


View products that this article applies to.

Symptoms

When a user uses smart card authentication to log on to a domain in Microsoft Windows Server 2003, only the logon certificate is propagated to the local certificate store of the user. The logon certificate is the key pair from the default container. Other certificates that are on the smart card are not propagated to the local certificate store of the user. For example, certificates for signing or encrypting e-mail messages are not propagated to the local certificate store of the user.

↑ Back to the top


Cause

This problem occurs when the smart card contains more than one certificate and when the secondary certificate is not a logon certificate.

↑ Back to the top


Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 64-bit versions
   Date         Time   Version      Size     File name     Platform
   ----------------------------------------------------------------
   18-Aug-2003  20:27  5.2.3790.78  219,648  Wlnotify.dll  IA-64
Windows Server 2003, 32-bit versions
   Date         Time   Version      Size    File name
   -----------------------------------------------------
   18-Aug-2003  20:32  5.2.3790.78  89,088  Wlnotify.dll

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was first corrected in Windows Server 2003 Service Pack 1.

↑ Back to the top


More information

After you install Windows Server 2003 Service Pack 1 (SP1) or this hotfix, when a user logs on by using smart card authentication, all certificates on the smart card are propagated to the local certificate store of the user. Programs such as Microsoft Outlook locate certificates by looking in this store. If an S/MIME certificate is stored on the smart card, it is propagated to this store. This behavior lets the user help secure e-mail by using a smart card.

↑ Back to the top


Keywords: kbautohotfix, kbhotfixserver, kbhotfixserver, kbqfe, kbwinserv2003sp1fix, kbbug, kbfix, kbwinserv2003presp1fix, kbqfe, KB826817

↑ Back to the top

Article Info
Article ID : 826817
Revision : 12
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 378