Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You cannot open more than 256 mailboxes by using WebDAV in Exchange Server 2003


View products that this article applies to.

Symptoms

When you create a program or a script to open many mailboxes by using Web Distributed Authoring and Versioning (WebDAV) in Microsoft Exchange Server 2003, you experience the following symptoms:
  • The first 256 mailboxes are opened successfully.
  • The program or script that you have configured to open mailboxes receives an HTTP 500 error message from the Internet Information Services (IIS) computer for each mailbox that it tries to open after the first 256 mailboxes have been opened.

↑ Back to the top


Cause

This problem occurs because each WebDAV client logon shares a single session. The WebDAV session pool code does not look beyond the first session in its free list when it searches for a session to use. Because there is a limit of 256 sequential logons in a single session, you experience this problem when you try to open more than 256 mailboxes.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required to install this hotfix.

Restart requirement

You do not have to restart your computer after you install this hotfix. However, all the following services are automatically stopped and then restarted when you install this hotfix:
  • MSExchangeIS
  • W3SVC
  • SMTPSVC
  • RESvc
  • POP3Svc
  • NntpSvc
  • IMAP4Svc
  • HTTPFilter
  • iisadmin

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   10-Jul-2003  21:42  6.5.6980.10     1,063,424  Davex.dll        
   10-Jul-2003  21:46  6.5.6980.10     3,618,816  Excdo.dll        
   10-Jul-2003  21:42  6.5.6980.10     2,536,448  Exoledb.dll      

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
817903� XADM: New naming schema for Exchange Server software update packages

↑ Back to the top


Keywords: KB826295, kbexchange2003presp1fix, kbbug, kbfix, kbqfe, kbqfe, kbhotfixserver, kbautohotfix

↑ Back to the top

Article Info
Article ID : 826295
Revision : 9
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 306