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You may receive an "E20251: Failed to enumerate the printers" error message when you run the Security Translation Wizard in Windows Server 2003


View products that this article applies to.

Symptoms

When you run the Security Translation Wizard in the Active Directory Migration Tool (ADMT) on a Microsoft Windows Server 2003-based computer to update the access control list (ACL) for printers, you may receive an error message that is similar to the following:
E20251: Failed to enumerate the printers on the local machine, rc=122 The data area passed to a system call is too small.
Additionally, this error message is also logged in the Migration.log file.

Note The Migration.log file is stored in the folder where you installed ADMT. Typically, this folder in the %Program Files%\Active Directory Migration Tool folder.

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Cause

This problem occurs because when you retrieve security information for a printer, ADMT checks if there is enough buffer to hold the data. If there is not enough buffer, a new buffer will be allocated. After ADMT successfully allocates the new buffer, the error status code is not cleared and you receive the error message that is mentioned in the "Symptoms" section.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version      Size     File name
   --------------------------------------------------------------------
   04-Aug-2003  17:08  5.2.3790.74  463,360  Mcsdctworkerobjects.dll  
   04-Aug-2003  17:08  5.2.3790.74  536,576  Mcsdctworkerobjectsnt4.dll  

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbhotfixserver, kbhotfixserver, kbqfe, kbwinservds, kbactivedirectory, kbfileprintservices, kbbug, kbfix, kbqfe, kbwinserv2003presp1fix, kbqfe, KB826275

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Article Info
Article ID : 826275
Revision : 10
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 338