Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Lsass.exe process may stop responding if you have many external trusts on a Windows 2000 Server-based domain controller


View products that this article applies to.

Symptoms

If you have many external trusts and many simultaneous logons where the domain is not specified on a Microsoft Windows 2000 Server-based domain controller, the Local Security Authentication Server (Lsass.exe) process may stop responding.

Note This problem does not apply to any logons where the domain is specified.

↑ Back to the top


Cause

This problem occurs because the Lsass.exe process runs out of resources if the number of simultaneous logons multiplied by the number of trusts is more than 1,000.

This problem typically will not occur. This problem may require hundreds of trusts and dozens of users who attempt simultaneous logons. For example, if the domain controller has 75 external trusts or downlevel trusts and the domain controller experiences 25 simultaneous logons where no domain specified, the number of logons multiplied by the number of trusts is 1,875 (25 logons x 75 trusts = 1,875). In this example, the Lsass.exe process would not be able to allocate enough resources to authenticate the client logon requests.

The problem can also occur more likely when a substantial number of domains are reachable onyl through an unreliable network link or are not reachable at all.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Adsldp.dll5.0.2195.6748124,68824-Jul-200300:10x86
Adsldpc.dll5.0.2195.6748132,36824-Jul-200300:10x86
Adsmsext.dll5.0.2195.674863,76024-Jul-200300:10x86
Advapi32.dll5.0.2195.6761381,71224-Jul-200300:10x86
Browser.dll5.0.2195.675369,39224-Jul-200300:10x86
Dnsapi.dll5.0.2195.6680134,92824-Jul-200300:10x86
Dnsrslvr.dll5.0.2195.678096,52824-Jul-200300:10x86
Eventlog.dll5.0.2195.675347,37624-Jul-200300:10x86
Kdcsvc.dll5.0.2195.6759148,24024-Jul-200300:10x86
Kerberos.dll5.0.2195.6758205,07218-Jun-200318:43x86
Ksecdd.sys5.0.2195.669571,88826-Mar-200322:37x86
Lsasrv.dll5.0.2195.6779509,71214-Jul-200305:17x86
Lsass.exe5.0.2195.677933,55214-Jul-200305:17x86
Msv1_0.dll5.0.2195.6786109,84018-Jul-200300:13x86
Netapi32.dll5.0.2195.6601311,56824-Jul-200300:10x86
Netlogon.dll5.0.2195.6791361,23224-Jul-200300:10x86
Ntdsa.dll5.0.2195.6784931,08824-Jul-200300:10x86
Samsrv.dll5.0.2195.6742392,46424-Jul-200300:10x86
Scecli.dll5.0.2195.6737131,34424-Jul-200300:10x86
Scesrv.dll5.0.2195.6737306,44824-Jul-200300:10x86
Sp3res.dll5.0.2195.67764,858,36815-Jul-200323:08x86
W32time.dll5.0.2195.660151,47224-Jul-200300:10x86
W32tm.exe5.0.2195.660157,10416-Aug-200214:32x86
Wldap32.dll5.0.2195.6741126,22424-Jul-200300:10x86

Hotfix installation instructions

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

You must create a new registry subkey to enable the functionality in the hotfix. After you enable the hotfix, the domain controller will no longer try to authenticate a domainless logon by querying external trusts.�

Important This new behavior may cause unwanted side effects if you have clients that do not send domain names with their logon requests. Such clients may include Microsoft Windows 98 clients and Microsoft Outlook Web Access. These programs will still work if the user account is in the Windows 2000 Server domain or in the global catalog. You should only experience problems if a user account is in an external domain.

To create the new registry subkey to enable the hotfix, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters
    .
  3. Right-click this subkey, point to New, click DWORD Value, type NeverPing, and then press ENTER.
  4. Right-click NeverPing, click Modify, type 1 in the Value data box, and then click OK.
  5. Exit Registry Editor.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows software update packages
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbnosurvey, kbarchive, kbautohotfix, kbbug, kbfix, kbwin2000presp5fix, kbqfe, kbhotfixserver, KB825107

↑ Back to the top

Article Info
Article ID : 825107
Revision : 5
Created on : 11/2/2013
Published on : 11/2/2013
Exists online : False
Views : 600