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Large UDP broadcast packets may not be received in Windows XP or in Windows Server 2003


View products that this article applies to.

Symptoms

When a program sends a large User Datagram Protocol (UDP) broadcast packet, the packet may not be received.

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Cause

When you send a UDP broadcast packet that must be fragmented, the IP checksum value may be calculated incorrectly. The computer that receives the UDP broadcast packet may identify the UDP broadcast packet as corrupted and discard the UDP broadcast packet. A UDP broadcast packet is fragmented when the UDP broadcast packet is larger than 1,500 bytes on an Ethernet II network. This problem originates on the Windows XP-based computer or on the Windows Server 2003-based computer that sends the packet.

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Resolution

Hotfix information

Windows XP Service Pack 1 and Service Pack 2

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Prerequisites

You must have Windows XP Service Pack 1 (SP1) or Service Pack 2 (SP2) installed.

Restart requirement

You must restart your computer after you install this hotfix

Update replacement information

This hotfix does not replace any other hotfixes

File information

Windows XP 32-bit versions, SP1
Date          Time   Version        Size     File name
------------------------------------------------------
18-Jul-2003   12:38  5.1.2600.1250  318,720  Tcpip.sys
Windows XP 64-bit versions, SP1
Date         Time   Version        Size       File name
--------------------------------------------------------
18-Jul-2003  12:38  5.1.2600.1250  1,092,992  Tcpip.sys
Windows XP 32-bit versions, SP2
Date         Time   Version            Size    File name
--------------------------------------------------------------
19-Aug-2004  07:00  5.1.2600.2507     359,040  Tcpip.sys

Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you install this hotfix

Update replacement information

This hotfix does not replace any other hotfixes

File information

Date         Time   Version           Size    File name
--------------------------------------------------------
14-May-2004  18:26  5.2.3790.172   334,336    Tcpip.sys

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

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More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbhotfixserver, kbqfe, kbwinxpsp2fix, kbqfe, kbwinxppresp2fix, kbfix, kbbug, kbprb, KB824838

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Article Info
Article ID : 824838
Revision : 7
Created on : 8/29/2007
Published on : 8/29/2007
Exists online : False
Views : 304