Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Dsmod Command Does Not Reset the Attribute Parameter of an Object


View products that this article applies to.

Symptoms

When you try to use the dsmod command to reset the parameter of an object to an empty value (NULL), the command appears to run successfully, but it does not change the attribute parameter. When you run dsmod and set the attribute parameter to "" (empty quotation marks), you expect the present parameter to be removed. However, if you use the Ldp.exe utility to view the object attributes, you notice that the attribute has not been changed.

↑ Back to the top


Cause

This problem occurs because when you use dsmod to reset an attribute to a NULL character, this generates an access violation and does not change the attribute, even though the command appears to run successfully. The access violation does not generate an error message, and there is nothing to indicate that the command did not run successfully.

↑ Back to the top


Resolution

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date          Time     Version          Size    File name
----------------------------------------------------------
04-Aug-2003  09:06     5.2.3790.74    144,384   Dsadd.exe
04-Aug-2003  09:06     5.2.3790.74    218,624   Dsget.exe
04-Aug-2003  09:06     5.2.3790.74    179,200   Dsmod.exe
04-Aug-2003  09:06     5.2.3790.74     33,280   Dsmove.exe
04-Aug-2003  09:06     5.2.3790.74    224,768   Dsquery.exe
04-Aug-2003  09:06     5.2.3790.74     37,376   Dsrm.exe

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

↑ Back to the top


Keywords: kbhotfixserver, kbqfe, kbbug, kbfix, kbqfe, kbwinserv2003presp1fix, kbautohotfix, KB824678

↑ Back to the top

Article Info
Article ID : 824678
Revision : 16
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 393