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Interrupts that come from a PCI device that uses a Windows NT 4.0-style driver are ignored in Windows Server 2003, Windows XP Professional, and Windows 2000


View products that this article applies to.

Symptoms

A computer that uses a Microsoft Windows NT Server 4.0-style device driver for a PCI device may lose interrupts from the device, and the device may not work correctly.

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Cause

This problem occurs because there is a code defect in the PCI bus driver (Pci.sys) that provides the required resources for the PCI device. As a result, the PCI driver does not allocate the correct interrupt request (IRQ) resources, and the Interrupt Service Routine for this device does not detect the interrupt.

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Resolution

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size    File name
   --------------------------------------------------------
   09-Sep-2002  19:34                  34,724  Ntdetect.com
   15-Jul-2003  00:46  5.0.2195.6781   59,344  Pci.sys
   12-Feb-2003  16:09  5.0.2195.6664  109,584  Pcmcia.sys

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

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More information

PCI bus drivers and the hardware abstraction layer (HAL) handle the resource allocation for Windows NT 4.0-style drivers differently than they do for WDM drivers. When you use the net start driver_name command to start the driver, the Windows NT 4.0-style driver typically asks for the resources, such as IO, Memory, IRQ, or other resources. When you run the net stop driver_name command, the Windows NT 4.0-style driver releases the acquired resources. The driver calls HAL routines, and these routines use the interface that the PCI bus driver provides.

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Keywords: kbarchive, kbautohotfix, kbhotfixserver, kbddk, kbbug, kbfix, kbqfe, kbwin2000presp5fix, kbnosurvey, KB824395

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Article Info
Article ID : 824395
Revision : 11
Created on : 1/10/2015
Published on : 1/10/2015
Exists online : False
Views : 295