Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Bridgehead servers with slow or poor links may not follow schedules defined in Active Directory for inbound replication in Windows Server 2003


View products that this article applies to.

Symptoms

Scheduled replications do not occur within their assigned 15 minute window when you are running Microsoft Windows Server 2003 domain controllers. Replications occur late and occupy time slots intended for replication of other connections.

This problem affects bridgehead domain controllers with a large number of inbound replication partners connected over wide area network connections (typically in remote Active Directory sites) with the following attributes:
  • Domain controllers in the hub site are connected to branch site DCs over slow and unstable network links.
  • The Active Directory replication frequency is scheduled to occur less often than every 5 hours.

↑ Back to the top


Cause

The bridgehead domain controllers occasionally expire network connections to servers that are no longer in use. When you have bridgehead domain controllers in hub sites of large Active Directory deployments, there can be many inbound connections from branch-site domain controllers which need to be expired. This can take some time and blocks pending inbound replication requests.

↑ Back to the top


Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   26-Aug-2003  00:08  5.2.3790.81     1,520,128  Ntdsa.dll        

↑ Back to the top


Workaround

The task in charge of cleaning up unneeded network connections in NTDSA periodically pre-empts itself to allow other tasks to run. Install this hotfix or Windows Server 2003 Service Pack 1 on all potential bridgehead domain controllers in the hub site that may have greater than 100 inbound connection objects. Realistically, you should install this hotfix or Windows Server 2003 Service Pack 1 on all existing Windows Server 2003 domain controllers in the forest. New domain controllers promoted into the forest should have this hotfix or Windows Server 2003 Service Pack 1 installed prior to running the Active Directory Installation Wizard, DCPROMO.EXE.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

↑ Back to the top


More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbhotfixserver, kbqfe, kbwinserv2003presp1fix, kbqfe, kbfix, kbbug, KB824335

↑ Back to the top

Article Info
Article ID : 824335
Revision : 13
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 439