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Wireless and VPN Clients Cannot Successfully Authenticate by Using EAP-TLS Authentication


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Symptoms

Wireless and virtual private network (VPN) clients may not be able to successfully authenticate by using Extensible Authentication Protocol-Transport Layer Security (EAP-TLS) authentication through a Microsoft Internet Authentication Service (IAS) installation on a Microsoft Windows Server 2003-based server.

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Cause

This problem may occur if IAS picks a certificate that is not valid for network access authentication -- for example, a certificate that contains a blank subject name. The selection of the certificate that is not valid causes TLS negotiations to fail both for VPN and for wireless connections.

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Resolution

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size      File name     Platform
   ------------------------------------------------------------------
   08-Aug-2003  19:32  5.2.3790.75   158,208   Rastls.dll    i386
   08-Aug-2003  19:33  5.2.3790.75   353,280   Rastls.dll    IA-64
   08-Aug-2003  19:32  5.2.3790.75   158,208   Wrastls.dll   IA-64 

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Workaround

On your server (or servers) that has IAS installed, open the remote access policies that use EAP, and then manually select the correct certificate.

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Status

Microsoft has confirmed that this is a problem in Windows Server 2003.

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Keywords: KB824069, kbwinserv2003presp1fix, kbqfe, kbfix, kbbug, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 824069
Revision : 17
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 301