Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

BizDesk Cannot Save Changes to Product Category Information


View products that this article applies to.

Symptoms

If you use Microsoft Commerce Server Business Desk (BizDesk) to modify a catalog, the property changes are not saved.

↑ Back to the top


Cause

This problem occurs because the PropertyName value is case sensitive and this value has been set to something other than ProdID. If the PropertyName value is not set correctly, BizDesk cannot save property changes.

↑ Back to the top


Resolution

To resolve this problem, follow these steps:
1.Open Commerce Server Manager.
2.Expand Microsoft SQL Servers. Continue to expand nodes until you locate your server and your database.
3.In the node for your Commerce database, right-click the CatalogDefinitionsProperties table, point to Open Table, and then click Query.
4.Modify the query to match the following, and then click the query (!) button:
SELECT * FROM CatalogDefinitionProperties WHERE (PropertyName = 'prodid')
5.If any results are returned, the PropertyName value is incorrectly set to Prodid.
6.Modify the each row in the query results by clicking directly in the PropertyName cell and typing ProdID.
7.Run the query that you ran in step 4 to verify that the values were changed. If the values were changed, the query does not return any rows.
8.Start BizDesk, and then try to modify the assignments on any of the Optioned Products.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

↑ Back to the top


Keywords: KB823481, kbfix, kbbug

↑ Back to the top

Article Info
Article ID : 823481
Revision : 1
Created on : 10/30/2003
Published on : 10/30/2003
Exists online : False
Views : 346