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Web Proxy Service Returns "The User Name Was Not Allowed" Error Message After the FTP Server Returns the "User Logged In" Message


View products that this article applies to.

Symptoms

When you try to connect to a FTP server through an ISA Server 2000 Web proxy service, you may receive the following error message:
HTTP 502 Proxy Error - The user name was not allowed. Try a different name, or retry the same name after verifying that it is typed correctly. (12013)
This problem may occur if all the following conditions are met:

Outbound scenario:
  • The Web proxy client connects to the external FTP server through the ISA Web proxy service.
  • The FTP server does not prompt for a password. After the FTP server has received the USER command from ISA Server, the server responds with 230 ("User logged in, proceed").
Inbound scenario (Web publishing):
  • The internal FTP server is published by a Web publishing rule on ISA Server. The Web publishing rule is set to Redirect HTTP requests as FTP requests. For more information about how to configure this setting, see the "More Information" section.
  • The FTP server does not prompt for a password. After the FTP server has received the USER command from ISA Server, the server responds with 230 ("User logged in, proceed").
Note The problem only occurs when the Web proxy service is used to connect to an FTP server. When the firewall service handles FTP traffic (such as server publishing, firewall requests, or SecureNAT client requests), this behavior does not occur.

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Cause

The ISA Server Web proxy service always expects to be prompted for a password after it sends the USER command to the FTP server. The FTP server prompts for a password by responding with a 331 response code. If the FTP server instead responds with 230 ("User logged in, proceed"), ISA Server misinterprets the results, and you receive the error message that is described in the "Symptoms" section.

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Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date          Time   Version       Size    File name
   ------------------------------------------------------
   22-June-2003  12:54  3.0.1200.278  30,992  W3pinet.dll 
				

Prerequisites

ISA Server 2000 Service Pack 1 (SP1) is required to install this hotfix. For additional information about how to obtain ISA Server Service Pack 1, click the following article number to view the article in the Microsoft Knowledge Base:
313139 How to Obtain the Latest Internet Security and Acceleration Server 2000 Service Pack

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

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More information

FTP servers may be configured to return 230 instead of the more typical 331 immediately after the server receives the USER command. Because a 230 response code translates to "User logged in, proceed", no PASS command is required. The hotfix changes the behavior of the ISA Server 2000 Web Proxy service to recognize the 230 response code as valid, and therefore the end of the authentication phase. For more information, see the FTP RFC (959).

To configure Redirect HTTP requests as FTP requests on the Web publishing rule:
  1. Open the ISA Server Microsoft Management Console (MMC).
  2. Expand Publishing.
  3. Expand Web Publishing Rules.
  4. Right-click the rule that you want to configure, and then click Properties.
  5. Click the Bridging tab.
  6. Click to select the Redirect HTTP requests as FTP requests check box.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

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Keywords: KB823261, kbbug, kbfix, kbisaserv2000presp2fix, kbqfe, kbhotfixserver, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 823261
Revision : 8
Created on : 6/14/2007
Published on : 6/14/2007
Exists online : False
Views : 410