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The connection times out for an OWA user who has a mailbox on an Exchange Server 5.5 computer


View products that this article applies to.

Symptoms

When a Microsoft Outlook Web Access (OWA) user connects to an OWA server, the OWA server may request mailbox data from the Microsoft Exchange Server 5.5 computer on which the user's mailbox resides. If the response from the Exchange Server 5.5 computer is delayed, the OWA server waits for a response for a predefined period of time. If other OWA users who have mailboxes on the same Exchange Server 5.5 computer try to log on to their mailboxes by using OWA, the delay on the OWA server increases exponentially. Eventually, the OWA user notices that an hourglass icon appears. The OWA user's connection times out after 15 minutes.

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Cause

This problem may occur if the following conditions are true:
  • You configure front-end servers that are used for OWA only.
  • You configure separate back-end Exchange Server 5.5 computers that store the Exchange Server 5.5 directory and the user mailboxes.
  • The Exchange Server 5.5 computer that stores the user mailboxes cannot be reached because of a network issue or because of another issue.
This problem may not be reported by users immediately. It may take some time to find the unresponsive Microsoft Exchange Server 5.5 computer if you have to troubleshoot the network.

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Resolution

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Restart Requirement

You do not have to restart the computer after you apply this hotfix. However, the Microsoft Exchange Server directory service and all dependent services are automatically stopped and restarted during the installation process.

Prerequisites

Because of file dependencies, this software update requires Microsoft Exchange Server 5.5 Service Pack 4 (SP4).

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
191014 How to obtain the latest Exchange Server 5.5 service pack

File Information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   29-Nov-2003  19:39  5.5.2657.80       507,152  Dsamain.exe      
   29-Nov-2003  19:36  5.5.2657.80       240,400  Dsmsg.dll        
   29-Nov-2003  19:36  5.5.2657.80       140,560  Emsabp32.dll     
   29-Nov-2003  19:36  5.5.2657.80        47,376  Oabgen.dll       

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Workaround

To work around this problem, install a separate server that handles only OWA 5.5. Then, configure the users who have mailboxes that are stored on the Exchange Server 5.5 computer that is periodically unavailable to connect through this OWA server. This configuration will isolate the symptoms to only those users who have mailboxes that are stored on the Exchange Server 5.5 computer that is periodically unavailable instead of affecting all OWA users.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

After you install the hotfix that is described in the Resolution section, you must change the Windows registry to enable event logging:
  1. On the OWA server, start Registry Editor. To do this, click Start, click Run, type regedt32 in the Open box, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Exchange\Exchange Provider
    Note You may have to create the Exchange Provider registry entry.
  3. On the Edit menu, click Add Value.
  4. In the Value Name box, type LogBindError, click REG_DWORD in the Data Type list, and then click OK.
  5. In the Data box, type 1, and then click OK.
After you enable event logging, the following event is logged when the problem that is described in the Symptoms section occurs:

Event ID: 1409
Event Type: Warning
Event Source: MSExchangeDS
Event Category: Field Engineering
Description: EMSABP (Exchange Address Book Provider) failed to bind to server: %1, with error %2 %n%n

This event alerts an administrator about the problem and about the source of the delay.

Note This hotfix does not prevent the delays on the OWA server. This hotfix only enables you to configure event logging so that an administrator knows the server or the network segment to troubleshoot.

The Name Service Provider Interface (NSPI) API that is used by MAPI clients for Microsoft Outlook Address Book lookups tries to contact the computer on which the user's mailbox resides. If this computer cannot be accessed because of a network issue, the OWA server may become unresponsive while it waits for a response to its RPC calls.

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Properties

Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

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Keywords: KB823247, kbfix, kbqfe, kbqfe, kbhotfixserver

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Article Info
Article ID : 823247
Revision : 5
Created on : 10/28/2006
Published on : 10/28/2006
Exists online : False
Views : 406