Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Majority node set clusters stop running on your Windows Server 2003-based network


View products that this article applies to.

Symptoms

The majority node set clusters on your Microsoft Windows Server 2003-based network may stop running. Additionally, you cannot restart the majority node set clusters in this scenario.

↑ Back to the top


Cause

This problem may occur if the quorum in a majority node set cluster becomes unsynchronized. In a majority node set cluster, data is replicated between all nodes of the cluster in a synchronous fashion. The shares on each majority node set cluster are kept synchronized by the Crs.log file. The Crs.log file is located in the root of each majority node set cluster. Every time that a share is changed, the operation that modifies the share is logged in the Crs.log file. Majority node set cluster shares remain synchronized by comparing the transactions that are logged in their respective Crs.log files with the Crs.log file of each of the other majority node set cluster shares.

The problem occurs when the Crs.log files of two majority node set clusters report that two cluster shares are synchronized, but a file is actually missing from one of the shares. This problem cannot be resolved if the cluster Crs.log files have grown sufficiently large that they wrap back to the beginning of the file and therefore write over the point where the inconsistency occurred. When a synchronization error occurs, the code that executes the majority node set resource may enter an infinite loop. This looping situation may cause the cluster to stop running, and then the cluster will not start again.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 64-bit editions
   Date         Time   Version            Size    File name	Platform
   ---------------------------------------------------------------------
   07-Jul-2003  23:31  5.2.3790.68     1,068,032  Clusres.dll      IA-64
   27-Jun-2003  23:29                        271  Branches.inf
   08-Jul-2003  00:00                     10,091  Kb823147.cat
   07-Jul-2003  23:35                        354  Updatebr.inf
   07-Jul-2003  23:35                      5,518  Update_rtmqfe.inf
Windows Server 2003, 32-bit editions
   Date         Time   Version            Size    File name	Platform
   ---------------------------------------------------------------------
   07-Jul-2003  23:29  5.2.3790.68       446,976  Clusres.dll	x86      
   27-Jun-2003  23:30                        271  Branches.inf
   08-Jul-2003  00:01                     10,091  Kb823147.cat
   07-Jul-2003  23:33                        354  Updatebr.inf
   07-Jul-2003  23:33                      5,934  Update_rtmqfe.inf

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbclustering, kbbug, kbfix, kbqfe, kbwinserv2003presp1fix, kbhotfixserver, KB823147

↑ Back to the top

Article Info
Article ID : 823147
Revision : 15
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 447