Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A 32-bit process calls the CreateProcess function but does not successfully start another 32-bit process


View products that this article applies to.

Symptoms

When one 32-bit process calls the CreateProcess function to start a second 32-bit process, the second 32-bit process does not start as expected.

If you use Performance Monitor to monitor the Private Bytes, the Virtual Bytes, and the Working Set counters of the 32-bit process that calls the CreateProcess function, you notice that the value of each counter increase over time. However, the Handle count value does not increase.

↑ Back to the top


Cause

This problem occurs because, when a 32-bit process calls the CreateProcess function to start another 32-bit process, a memory leak occurs in the 32-bit process that made the CreateProcess call. The second process cannot start because there is not sufficient memory left to run the process.

↑ Back to the top


Resolution

Update information

English

The following file is available for download from the Microsoft Download Center:
Download the WindowsServer2003-KB822961-ia64-ENU.exe package now. Release Date: October 22, 2003

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

Japanese

The following file is available for download from the Microsoft Download Center:
Download the package now.

French/German

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart you computer after you install this update.

Update replacement information

This update does not replace any other updates.

File information

   Date         Time   Version      Size     File name
   ----------------------------------------------------
   04-Jul-2003  01:54  5.2.3790.67  449,536  Wow64.dll 

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB822961, kbwinserv2003presp1fix, kbqfe, kbfix, kbbug, kbqfe, atdownload

↑ Back to the top

Article Info
Article ID : 822961
Revision : 12
Created on : 10/26/2006
Published on : 10/26/2006
Exists online : False
Views : 521