Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

How to troubleshoot error messages that you receive in Word (Part 3)


View products that this article applies to.

Summary

This article is part 3 of a series of three Microsoft Knowledge Base articles that describe how to troubleshoot error messages in Microsoft Office Word 2007, in Microsoft Office Word 2003, or in Microsoft Word 2002.

For more information about how to troubleshoot error messages in Word, click the following article numbers to view the articles in the Microsoft Knowledge Base:
822645 How to troubleshoot error messages that you receive in Word 2003 or in Word 2002 (Part 1)
822646 How to troubleshoot error messages that you receive in Word 2003 or in Word 2002 (Part2)

↑ Back to the top


More information

You can continue to troubleshoot invalid page faults and exception errors by using the following steps after you complete parts 1 and 2 in this series of articles.

The following topics are covered in part 3 of this article:

IN THIS TASK

Use Safe Mode

By this point, the invalid page fault or exception error is difficult to solve, and you may have to have a different approach to troubleshooting. The rest of this article describes a troubleshooting method where you start Microsoft Windows in Safe Mode and then start Microsoft Word by using the/a switch. If this method does not work, the problem may be related to a bad installation of Microsoft Office, Word, or Windows. If this method works, you will be presented with several more ideas for solutions.

Start Windows in Safe Mode

Safe Mode is a method to start your computer so that Windows starts in the simplest way possible. Safe Mode bypasses many drivers and supporting files that can cause problems if they are damaged.

For more information about how to start Windows in Safe Mode, click the following article numbers to view the articles in the Microsoft Knowledge Base:
310353 How to perform a clean boot in Windows XP
202485 Description of Safe Boot Mode in Windows 2000

Start Windows Server 2003 in Safe Mode

  1. Click Start, and then click Shut Down.
  2. Click Restart, and then click OK.
  3. When you receive the following message, press F8:
    Please select the operating system to start
  4. In Windows Advanced Option Menu, use the arrow keys to select Safe Mode, and then press ENTER.

    Note NUM LOCK must be turned off before the arrow keys on the numeric keypad will function.
  5. If you are running other operating systems on the computer, click Microsoft Windows Server 2003 on the list that appears, and then press ENTER.

Start Word as cleanly as possible

In this procedure, you start Windows in Safe Mode and start Word by using the /a switch. This starts Word in the most basic environment possible.

To do this, follow these steps:
  1. Start Windows in Safe Mode by following the steps in the "Start Windows in Safe Mode" section earlier in this article.
  2. Start Word by using the /a switch.

    To do so, follow the steps that are outlined in the "Start Word with the /a Switch" section in the following article:
    822645 How to troubleshoot error messages that you receive in Word 2003 and in Word 2002 (Part 1)
  3. Try to reproduce the problem.
If the problem does not occur, follow the steps in the "Start Word with Windows in Safe Mode" section later in this article.

If the problem still occurs, follow the steps in the "Remove Word or Office" section later in this article.

Start Word with Windows in Safe Mode

In this procedure, you take one step back from the extreme restarting procedure that is mentioned earlier in this article. Windows starts in Safe Mode, and Word starts as it typically does. To do this, follow these steps:
  1. Start Windows in Safe Mode by following the steps in the "Start Windows in Safe Mode" section earlier in this article.
  2. Start Word as you typically do (without using the /a switch) and try to reproduce the problem.
If the problem occurs, the problem may be caused by a damaged Normal.dot file or a damaged Normal.dotm file in Word 2007, a data key, or an item in the Startup folder. Follow the steps in the "Reset Word back to default settings" section in part 1:
822645 How to troubleshoot error messages that you receive in Word 2003 or in Word 2002 (Part 1)
If the problem does not occur, continue to troubleshoot the problem by following the steps in the next section of this article.

Back to topics

Repair Word or Office

If the invalid page fault or exception error still occurs, Word or Office files may have become damaged. This section guides you through a process of removing and reinstalling Word or Office to get the cleanest possible reinstallation.

The easiest way to correct a Word or Office installation is to run a Repair Office (or Repair Word). Although this is very fast and frequently corrects the problem, there are situations when it does not correct the problem and you may have to perform a complete removal and reinstallation.

To perform a repair of Word or Office, follow these steps as appropriate to your operating system.

Microsoft Windows 2000

  1. Quit all programs that are running.
  2. Click Start, point to Settings, and then click Control Panel.
  3. Double-click Add/Remove Programs.
  4. Click the Office or stand-alone version of Word that you have installed, and then click Add/Remove, for example, click Microsoft Office Word 2003, Microsoft Office Standard Edition 2003, or Microsoft Office Professional 2003.
  5. After you enter the Setup program, click Repair Office (or Repair Word).

Microsoft Windows XP

  1. Quit all programs that are running.
  2. Click Start, and then click Control Panel.
  3. Double-click Add or Remove Programs.
  4. Click the Office or stand-alone version of Word that you have installed, and then click Change, for example, click Microsoft Office Word 2003, Microsoft Office Standard Edition 2003, or Microsoft Office Professional 2003.
  5. After you enter the Setup program, click Repair Office (or Repair Word).
The Setup program checks the files that are installed and replaces or installs any files from an earlier version that are the wrong size, damaged, or missing. After the Setup is complete, restart Word as you typically do (without using the /a switch), and then try to reproduce the problem.

If the problem is corrected, you may have identified the problem as being a damaged file. If Word does not work correctly, continue to troubleshoot the problem by using the steps in the "Remove Word or Office" section of this article.

Back to topics

Remove Word or Office

This procedure guides you through the steps to remove as much of Word or Office as possible. After the removal, you can install Word or Office again.

Caution This procedure can result in data loss. Before you follow these steps, you must back up any user files that may be important. This includes custom templates, documents, and the Normal.dot file or the Normal.dotm file.

Use the Setup program to remove as many files as possible. To use Setup to remove Word or Office, follow these steps.

Windows 2000

  1. Quit all programs that are running.
  2. Click Start, point to Settings, and then click Control Panel.
  3. Double-click Add/Remove Programs.
  4. Click the Office or stand-alone version of Word that you have installed, and then click Add/Remove, for example, click Microsoft Office Word 2003, Microsoft Office Standard Edition 2003, or Microsoft Office Professional 2003.
  5. From the Setup program, click Uninstall, and then click Yes to confirm the removal.
  6. When you are prompted to remove shared components, click Remove All.

Windows XP

  1. Quit all programs that are running.
  2. Click Start, and then click Control Panel.
  3. Double-click Add or Remove Programs.
  4. Click the Office or stand-alone version of Word that you have installed, and then click Remove, for example, click Microsoft Office Word 2003, Microsoft Office Standard Edition 2003, or Microsoft Office Professional 2003.
  5. Click Yes to confirm the removal.
  6. When you are prompted to remove shared components, click Remove All.

Clean the system

Note Make sure that you have backed up your documents, templates, and the Normal.dot file or the Normal.dotm file before you follow these steps.
  1. Delete the Office installation folders. To do so, follow these steps:
    1. Right-click Start, and then click Explore.
    2. Click the following folder:
      C:\Program Files\Microsoft Office\
    3. On the File menu, click Delete.
    4. When you are prompted to confirm the deletion, click Yes.
    5. Click the following folder:
      C:\Program Files\Common Files\Microsoft Shared
    6. On the File menu, click Delete.
    7. When you are prompted to confirm the deletion, click Yes.
    8. On the File menu, click Close to quit Windows Explorer.
  2. Use the Disk Cleanup tool to remove files that you do not require from your computer.

    To do this, click Start, point to Programs (in Windows XP, point to All Programs), point to Accessories, point to System Tools, and then click Disk Cleanup.
  3. Delete temporary files from your computer. To do this, follow these steps.

    Note Make sure that you quit all Windows programs before you continue with these steps.

    Windows XP
    1. Click Start, and then click Search.
    2. In the All or part of the file name box, type the following:
      ~*.*
      Caution Make sure that you type the tilde character (~) as the first character. Failure to do this may result in deletion of all the files on your system.

      Note If you do not see the All or part of the file name box, click All files and folders.
    3. Change the Look in box either to the drive that you want to search or to Local Hard Drives.
    4. Click Search.
    5. After Search Results completes the search, click Select All on the Edit menu.
    6. On the File menu, click Delete.
    7. Click Yes to confirm the deletion of the files.
    8. Repeat steps a through g and type *.tmp in the All or part of the file name box of step b.
    Windows 2000
    1. Click Start, point to Search, and then click For Files or Folders.
    2. In the Search for files or folders named box, type ~*.*

      Caution Make sure that you type the tilde character (~) as the first character. Failure to do this may result in deletion of all files on your system.
    3. In the Look in list, select your local hard disk.
    4. Click Search Now.
    5. After the search completes, click Select All on the Edit menu.
    6. On the File menu, click Delete.
    7. Click Yes to confirm the deletion of the files.
    8. Repeat steps a through g and type *.tmp in the Search for files or folders named box of step b.
  4. To check your hard disk for errors, run the ScanDisk utility.

    Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
    1. On the Windows desktop, double-click My Computer.
    2. Select the disk that you want to check.
    3. On the File menu, click Properties, and then click the Tools tab.
    4. In the Error-checking section, click Check Now.
    5. In the Check disk options section, click to select the Scan for and attempt recovery of bad sectors check box, and then click Start.
  5. To defragment the files and free up space on your hard disk, run the Disk Defragmenter utility.

    On the Start menu, point to Programs, (for Windows XP point to All Programs), point to Accessories, point to System Tools, and then click Disk Defragmenter.
  6. Click Start, and then click Shutdown.
  7. In the Shut Down Windows dialog box, click Restart, and then click OK.
Back to topics

Reinstall Word or Office

At this point, most traces of Word or Office have been removed from the computer and the system is optimized. You can now run Word or Office Setup from the original location to install the programs.

After Setup is complete, start Word as you typically do (without using the /a switch), and then try to reproduce the problem.

If the problem is corrected, you may have identified the problem as being a damaged file.

If Word does not work correctly, continue to troubleshoot the problem by using the steps in the "Reinstall Windows" section of this article.

Back to topics

Reinstall Windows

By this point, the invalid page fault or exception error may be caused by a damaged Windows file. You may want to obtain additional Windows technical support help by using one of the methods listed in the "Microsoft support options" section of this article.

For more information about how to install Windows, click the following article numbers to view the articles in the Microsoft Knowledge Base:
316941 How to install or upgrade to Windows XP
250297 How to prepare to upgrade Windows 95 or Windows 98 to Windows 2000
Back to topics

Microsoft support options

If you cannot resolve this issue, several support options are available to help you.

Quickly find answers online

Use Microsoft Online Support to search the Microsoft Knowledge Base and other technical resources for fast, accurate answers. You can also customize the site to control your search.

To start your search, visit the following Microsoft Web site:

Microsoft Product Support

Contact a Microsoft Product Support professional to help you with troubleshooting problems.

For more information about how to obtain help with troubleshooting in Windows, click Help Topics on the Help menu in Windows Explorer. On the Contents tab, double-click the Troubleshooting book. Double-click the Contact Microsoft Product Support Services book to view your support options.

For more information about how to obtain help with troubleshooting in Word, click About Microsoft Word on the Help menu, and then click Tech Support.

Microsoft Service Providers

Microsoft Service Providers are independent organizations that have teamed with Microsoft to use technology to solve business problems for companies of all sizes and industries.

To locate a Microsoft Service Provider in your area in the United States and Canada, call the Microsoft Sales Information Center at (800) 426-9400. If you are outside the U.S., contact your local subsidiary. To locate your subsidiary, visit the following Microsoft Worldwide Offices Web site:
Back to topics

↑ Back to the top


Keywords: KB822648, kberrmsg, kbhowto, kbtshoot

↑ Back to the top

Article Info
Article ID : 822648
Revision : 7
Created on : 9/18/2011
Published on : 9/18/2011
Exists online : False
Views : 312