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You experience slow printer performance on a clustered print server in Windows Server 2003 and in Windows 2000 Server


View products that this article applies to.

Symptoms

You may experience slow printing performance on a Windows Server 2003-based or Windows 2000 Server-based server cluster that is configured as a printer spooler. When you troubleshoot this problem, the following behavior occurs:
  • Print jobs take an increasingly long time to print.
  • If you fail over the cluster node to another node, the problem recurs.
  • If you edit the Windows registry on the cluster node to increase the node's number of connections to itself, the problem recurs.
  • Under the Shared Folders\Open Files administrative snap-in, in Computer Managment\System Tools, the server shows multiple Open File connections to \PIPE\spoolss. These connections do not list an owner.

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Cause

This problem may occur if the Print Spooler service stops responding (hangs). A scenario may occur where the Print Spooler service loops back on itself when it makes a remote call (RemoteGetPrinter) to a local printer. This behavior causes the Print Spooler service to exhaust all the server's available connections to itself. The Print Spooler service stops responding because it is waiting on a thread that is trying to load a print driver.

This problem may occur if you try to open a connection to a shared printer that no longer exists. For example, this problem may occur in the following scenarios:
  • A printer share is renamed, and you try to connect to the printer by using the old name.
  • A network printer is local to a cluster node, and you try to connect to it when the cluster node fails over.
In these cases, the Print Spooler service routes the incoming OpenPrinter call to local print spoolers (including the cluster). If the local print spoolers do not recognize the requested printer name, the spooler passes the calls to the remote print provider (Win32spl.dll).

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Resolution

Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
No prerequisites are required to install this hotfix.
Restart requirement
You must restart your computer after you apply this hotfix. However, if you want to restart the computer later, click to select the Do not restart now check box before you click Finish when you install the hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003 32-bit versions
   Date         Time   Version        Size  File name
   -----------------------------------------------------
   11-Jun-2003  22:44  5.2.3790.54  93,696  Win32spl.dll
Windows Server 2003 64-bit versions
   Date         Time   Version        Size   File name     Platform
   ----------------------------------------------------------------
   11-Jun-2003  22:36  5.2.3790.54  274,944  Win32spl.dll
IA-64

Windows 2000 Server

Hotfix information

A supported hotfix is now available from Microsoft. For additional information about this hotfix, click the following article number to view the article in the Microsoft Knowledge Base:
886679� A printer connection that is bridged between Windows 98 and Windows Server 2003 or Windows 2000 Server stops working

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

The hotfix that is described in this article prevents the remote print provider (Win32spl.dll) from looping back to the same computer that called it.

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Keywords: kbautohotfix, kbhotfixserver, kbqfe, kbbug, kbfix, kbqfe, kbwinserv2003presp1fix, KB822553

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Article Info
Article ID : 822553
Revision : 12
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 458