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"Multiple Components Cannot Be Assigned the Requested Action" Error Message During Exchange 2003 Installation


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Symptoms

When you try to install Microsoft Exchange Server 2003, you may receive the following error message:
Multiple components cannot be assigned the requested action

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Cause

This issue may occur if you do not have sufficient permissions when you try to install Exchange Server 2003.

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Resolution

To resolve this issue, run Setup again by using an account that has the following administrative credentials:
  • Exchange Full Administrator for the appropriate organization or the appropriate administrative group (depending on your Exchange configuration).

    -and-
  • Administrator rights on the local computer that you want to install Exchange 2003 on.

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More information

During the ForestPrep operation, you are prompted to choose an account to grant Exchange Full Administrator rights to. When you install Exchange 2003 on the first server, you must use this account to run Setup. After Exchange 2003 is installed on the first server, you can use the Exchange System Manager to delegate additional accounts that have Exchange Full Administrator rights.

To do this, follow these steps:
  1. Start Exchange System Manager.
  2. Right-click Your Organization Name, and then click Delegate Control.
  3. Click Next.
  4. Click Add, click Browse, click the user or the group that you want to delegate permissions to, and then click OK.
  5. Under Role, click Exchange Full Administrator, and then click OK.
  6. Click Next, and then click Finish to complete the wizard.
To determine the account that was granted Exchange Full Administrator rights during ForestPrep, examine the Exchange Server Setup Progress.log file:
  1. Locate the "Exchange Server Setup Progress.log" file. The file is located on the root of the system drive on the computer where you ran the setup /forestprep command.
  2. Open the file with a text editor such as Notepad.
  3. Press CTRL+END to position the pointer at the end of the file.
  4. On the Edit menu, click Find.
  5. In the Find What box, type PTAdministratorAccount.
  6. Click Up, and then click Find Next.
  7. Click Cancel to close the Find dialog box.
  8. Locate the line that looks similar to the following, where User is the account that was granted Exchange Full Administrator rights during ForestPrep:
     
    [17:13:19] PTAdministratorAccount = <DOMAIN>\<User>
    
    

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Keywords: KB822439, kbbug, kbpending, kberrmsg

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Article Info
Article ID : 822439
Revision : 5
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 223