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User cannot create a Terminal Server roaming profile path if a user with the same name has logged on from another domain


View products that this article applies to.

Symptoms

When you configure the Set path for TS Roaming Profiles Group Policy setting, this setting does not work as expected. Specifically, if two users with the same user name in different domains log on to a Microsoft Windows Server 2003-based terminal server, they cannot access their Terminal Server roaming profiles.

When this problem occurs, the following entry appears in the Application log:

Event Type: Error
Event Source: Winlogon
Event Category: None
Event ID: 1219
Date: 5/27/2004
Time: 9:35:22 AM
Description: Logon rejected for user_name. Unable to obtain Terminal Server User Configuration. Error: The RPC server is unavailable.

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Cause

This problem occurs when both of the following conditions are true:
  • Users with the same user name are hosted in different domains.
  • One of those users has logged on to the terminal server and has created a roaming profile.
For example, in a scenario where the following users exist
username1@example.com
username1@domain.example.com
if username1@example.com logs on to the terminal server, a roaming profile that is named "username1" is created. When username1@domain.example.com logs on, username1@domain.example.com cannot access the existing username1 profile. After you apply this hotfix, each user receives a unique profile name with a format of username.domain.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer to apply the changes after you apply this hotfix. However, you do not have to restart the computer immediately after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, 32-bit versions
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   14-Jul-2003  21:58  5.2.3790.68       538,624  Winlogon.exe   
Windows Server 2003 64-bit Itanium-based versions
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   11-Jul-2003  19:39  5.2.3790.68       635,904  Winlogon.exe     IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

After you apply this hotfix, Windows determines the location of the user's home directory by using the following logic when a user logs on:
  1. Try to locate the ...\UserName.Domain path. If it exists and the user has full control permissions configured in the folder, this path is used for the home directory.
  2. If ...\UserName.Domain is not accessible or does not exist, try to access ...\UserName.
  3. If ...\UserName exists and the user has Full Control permissions to it, this path is used for the home directory.
  4. If ...\UserName is not accessible, create ....\UserName.Domain with full control permission. This path is used for the home directory.
For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB821929, kbwinserv2003presp1fix, kbqfe, kbfix, kbbug, kbenv, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 821929
Revision : 13
Created on : 1/3/2008
Published on : 1/3/2008
Exists online : False
Views : 512