Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Performance Counter Instance Appears Several Times When You Combine Log Files by Using Relog.exe


View products that this article applies to.

Symptoms

After you run the Relog.exe command to append one or more .blg log files to an existing performance monitoring log file, when you view the log file information, extra counters appear for the same instances in the Performance tool. For example, before you run the Relog.exe command to combine log files, the Add Counters dialog box for the Process performance object is similar to the following:
Select counters from listSelect instances from list
% Processor Timesvchost#1
svchost#2
However, after you run the Relog.exe command, the Add Counters dialog box is similar to the following:
Select counters from listSelect instances from list
% Processor Timesvchost#1
svchost#1#1
svchost#2
svchost#2#1
You expect the same instances from different log files to be combined and to be listed as a single instance.

↑ Back to the top


Cause

This problem occurs when both of the following conditions are true:
  • You append one or more .blg log files to an existing performance monitoring log file.
  • The performance counter instances end with the number sign (#) index.

↑ Back to the top


Resolution

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart Requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-Bit Editions
   Date         Time   Version      Size     File name
   ----------------------------------------------------
   23-Jul-2003  21:55  5.2.3790.71  282,112  Pdh.dll
Windows Server 2003, 64-Bit Edition
   Date         Time   Version      Size     File name  Platform
   --------------------------------------------------------------
   23-Jul-2003  21:58  5.2.3790.71  747,008  Pdh.dll    IA-64
   23-Jul-2003  21:55  5.2.3790.71  282,112  Wpdh.dll   x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

↑ Back to the top


More information

For additional information about the terminology that is used to describe Microsoft product updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the Standard Terminology That Is Used to Describe Microsoft Software Updates

↑ Back to the top


Keywords: kbhotfixserver, kbqfe, kbbug, kbfix, kbqfe, kbwinserv2003presp1fix, kbautohotfix, KB821541

↑ Back to the top

Article Info
Article ID : 821541
Revision : 17
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 357