Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Messages that are sent through an X.400 connector may remain in the outgoing X.400 queue


View products that this article applies to.

Symptoms

When users send outgoing messages through an X.400 connector, those messages may remain in the outgoing X.400 protocol queue. The messages are not delivered. If you remove the first message from the queue, messages may be delivered successfully but may then again become stuck in the outgoing queue.

↑ Back to the top


Cause

This problem occurs when a user who sends a message has an X.400 proxy address that contains a given name, but that does not contain a surname. An X.400 proxy address that contains a given name, but that does not contain a surname, is unsupported by Microsoft Exchange 2000 Server because this is not a valid X.400 address. Because this is an invalid X.400 address, Exchange 2000 Server should return the message to the sender as undeliverable, but it does not.

↑ Back to the top


Resolution

Cumulative Rollup Information

To resolve this problem, obtain the September 2003 Exchange 2000 Server Post-Service Pack 3 (SP3) Rollup. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824282 September 2003 Exchange 2000 Server post-Service Pack 3 rollup

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Component: MTA
Date         Time   Version            Size    File name
-----------------------------------------------------------
14-Jun-2003  02:23  6.0.6476.0      1,798,144  Emsmta.exe
14-Jun-2003  02:14  6.0.6476.0         40,960  X400omv1.dll
Note Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3 (SP3). For more information, click the following article number to view the article in the Microsoft Knowledge Base:
301378 How to obtain the latest Exchange 2000 Server service pack
After you install this update, Exchange 2000 Server generates a non-delivery report (NDR) when it receives a message from a recipient who has an invalid X.400 proxy address (as described in the "Cause" section of this article). You must correct the X.400 proxy address for each user who has an invalid address.

↑ Back to the top


Workaround

To work around this problem, manually remove the message that is stuck from the X.400 remote delivery queue, and then make sure that the there is a valid surname in the user's X.400 proxy address.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB821177, kbbug, kbexchange2000presp4fix, kbfix, kbqfe, kbhotfixserver, kbautohotfix

↑ Back to the top

Article Info
Article ID : 821177
Revision : 8
Created on : 10/26/2006
Published on : 10/26/2006
Exists online : False
Views : 218