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UDDI Services Installation Fails on Computers That Use a Turkish System Locale


View products that this article applies to.

Symptoms

When you try to install Universal Description, Discovery, and Integration (UDDI) Services on a computer that uses a Turkish system locale, the installation does not complete successfully.

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Cause

This problem occurs because the Setup program misinterprets the lowercase and the uppercase letter "i" in the Turkish language. This causes a problem in the UDDI Services installation because several SQL scripts that are used during setup declare an entityTypeID variable, but entityTypeid is used instead. Because of the way Setup interprets the "i," SQL misinterprets entityTypeid as a new, undeclared variable, and then throws an error.

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Resolution

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart Requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size       File name
   ------------------------------------------------------
   21-Oct-2003  21:57  6.0.4039.0  1,148,416  Acuddi.dll

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

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Keywords: KB821170, kbwinserv2003presp1fix, kbhotfixserver, kbqfe, kbfix, kbbug, kbautohotfix

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Article Info
Article ID : 821170
Revision : 15
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 320