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Cannot Set the userPassword Attribute in Active Directory


View products that this article applies to.

Symptoms

When you try to set the userPassword attribute by using an LDAP Data Interchange Format (LDIF) file, you receive an error message that is similar to the following:
Add error on line 34: Unwilling To Perform
This problem occurs after you create the following configuration in your Microsoft Windows Server 2003 Active Directory directory services schema and then try to set the userPassword attribute:
  • You extend the Active Directory schema to add a custom object class.
  • You create a new object that is based on that custom object class, and you include the userPassword attribute in the set of attributes for that object.

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Cause

This problem occurs because the userPassword attribute does not correctly allow write access when it is part of the attribute set for a custom object class in an extended Active Directory schema.

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Resolution

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer to apply the changes after you install this hotfix. However, you do not have to restart your computer immediately after you install this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-Bit Editions
   Date         Time   Version      Size       File name
   ------------------------------------------------------
   09-May-2003  22:31  5.2.3790.21  1,384,448  Ntdsa.dll
Windows Server 2003, 64-Bit Edition
   Date         Time   Version      Size       File name  Platform
   ----------------------------------------------------------------
   09-May-2003  22:25  5.2.3790.21  4,008,448  Ntdsa.dll  IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

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More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the Standard Terminology That Is Used to Describe Microsoft Software Updates

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Keywords: KB820856, kbwinserv2003presp1fix, kbqfe, kbfix, kbbug, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 820856
Revision : 15
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 345