Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Setupldr.efi file cannot read the Automated System Recovery disk or the Winnt.sif file from a USB floppy drive in Windows Server 2003


View products that this article applies to.

Symptoms

When you use a Winnt.sif file on a floppy disk to perform an unattended Microsoft Windows Server 2003 installation, the Setupldr.efi file cannot access the Winnt.sif file from a universal serial bus (USB) floppy drive. When you boot from a USB floppy drive, the installation settings in the Winnt.sif file will not be used. This problem may also affect the Windows 2000 Automated System Recovery (ASR) disk because the Setupldr.efi file cannot retrieve the data on the ASR floppy disk in a USB floppy drive.

↑ Back to the top


Cause

This problem occurs because Windows Server 2003 cannot retrieve the settings from some USB floppy drives.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   03-Jul-2003  00:07  5.2.3790.67       840,192  Setupldr.efi

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


There are three methods that you can use to install this fix with the existing images.

The first method is to create a CD with the Setuplds.efi file as the boot sector. To do this, follow these steps:
  1. Use the Xcopy.exe tool to copy the image to a temporary location on your hard disk. For example, copy it to the C:\TempImage folder.
  2. Copy the Setupldr.efi file to a floppy disk, and then copy the file to the image folder. For example, copy the file to the C:\TempImage\Image folder.
  3. Image the floppy disk by using the image on the hard disk with a utility. You can use the DiskImage utility that is provided in the OEM Preinstallation Kit, which is part of the Server Appliance Kit (SAK) for Windows Server 2003. For more information about the OEM Preinstallation Kit (OPK) for Windows Server 2003, visit the following Microsoft Web site:
    http://msdn2.microsoft.com/en-us/library/ms853187.aspx
  4. Use the OPK tools or third-party software to create the International Standards Organization (ISO) image with the floppy disk image that is provided as the boot sector. For example, type oscdimg -n -b.\FloppyImage c:\TempImage\image c:\OS_cd.iso.
  5. At the Extensible Firmware Interface (EFI) menu, click EFI Shell, and then change to the CD drive. (This drive is typically fs0:.) Run the Setupldr.efi file from the shell. Make sure that the Winnt.sif file is on a floppy disk in the USB floppy drive.

The second method is to copy the Setupldr.efi file on to the hard disk from another computer that is running Windows Server 2003. To do this, follow these steps:
  1. Copy the Setupldr.efi file to a formatted floppy disk.
  2. Click Start, click Run, and in the Open: box, type cmd, and then click OK.
  3. Locate the Winnt32.exe file in the Windows Server 2003\version\I386 folder. For example, look for the file in D:\Windows Server 2003\Standard\I386.
  4. Type Winnt32.exe /NoReboot to initiate an installation of Windows Server 2003. Do not use an unattended answer file during this phase.
  5. After the Winnt32.exe program is completed, replace the Setupldr.efi file that is on the root of the EFI System Partition (ESP) with the new version. For example, type mountvol /s g:. This mounts the ESP to drive letter G.
  6. Type copy \setupldr.efi g:\ /y to make sure that you overwrite the old Setupldr.efi file on the ESP with the new version from the floppy disk.
  7. Put in the floppy disk that contains the Winnt.sif file in the USB floppy drive, and then restart the computer. The text mode boot cycle will automatically pick up the new Setupldr.efi file.
If you do not have access to the OPK, you can use the following method to create a CD with Setupldr.efi as a startup program:
  1. Use the Xcopy.exe tool to copy the original CD image to a temporary location on your hard disk. For example, copy the image to the C:\TempImage folder.
  2. Copy the Setupldr.efi file to a formatted floppy disk.
  3. Start a third-party CD-ROM burning program that lets you create a startup CD. Specify the C:\TempImage folder as the source of CD files. Specify the floppy disk that you used in step 2 as the source of the startup image. See the CD-ROM burning software documentation for details.
  4. Put the CD in the CD drive, and then start the target system. At the Extensible Firmware Interface (EFI) menu, click EFI Shell, and then change the current drive to the CD. (This drive is typically fs0:.) Run the Setupldr.efi file from the shell. Make sure that the ASR disk or a floppy disk that contains the Winnt.sif file is in the USB floppy drive.

REFERENCES

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
817708 "Setup Was Unable to Format the Drive" error message appears during ASR restore

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbwinservsetup, kbbug, kbfix, kbqfe, kbwinserv2003presp1fix, kbhotfixserver, KB820364

↑ Back to the top

Article Info
Article ID : 820364
Revision : 17
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 572