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Error 0x800cc800 during Exchange clustered resource failover


View products that this article applies to.

Symptoms

If the IIS Admin service crashes on a server that is running Microsoft Clustering Service (MSCS), and the Exchange virtual server resource then fails over to the other node in the cluster, you may not be able to move the Exchange virtual server resource back to the node that experienced the crash. When this behavior occurs, you see the following error in the application log in Event Viewer:

Event Type: Warning
Event Source: IMAP4SVC
Event Category: General
Event ID: 1036
Description: An error occurred while starting the Microsoft Exchange IMAP4 Service: server instance number 1 failed to start with error 0x800cc800.
For more information, click http://search.support.microsoft.com/search/?adv=1.
Data: 0000: 002d0179

You will also see the following error in the system log, indicating that the IIS Admin service crashed:

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7031
Description: The IIS Admin Service service terminated unexpectedly. It has done this 3 time(s). The following corrective action will be taken in 1 milliseconds: Run the configured recovery program.

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Cause

When the IIS Admin service fails on a cluster, the Exchange cluster resource DLL (Exres.dll) tries to restart the IIS Admin service and the Exchange services that depend on the IIS Admin service. By default, IISRESET is configured to run when the IIS Admin service fails; therefore, the Service Control Manager runs IISRESET separately to restart the IIS Admin service. When this occurs, Exchange services that depend on the IIS Admin service for access to configuration information that is stored in the metabase may not recognize that the IIS Admin service has been restarted. Two Exchange services that depend on the IIS Admin service are Post Office Protocol (POP) and Internet Message Access Protocol (IMAP). When the Exchange services do not recognize that the IIS Admin service has been restarted, the services do not renew their metabase interfaces, and the error occurs when Exchange tries to fail over.

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Workaround

To work around this problem, manually restart the IIS Admin service on any node where you see these errors in your Event Viewer logs. This forces the Exchange services to renew their metabase interfaces so that the Exchange virtual server can fail over to the node again.

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Resolution

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   13-May-2003  19:54  5.0.2195.6743      28,432  Admexs.dll       
   13-May-2003  19:54  5.0.2195.6743      16,656  Iisadmin.dll   

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

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Keywords: KB819865, kbhotfixserver, kbqfe, kbbug

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Article Info
Article ID : 819865
Revision : 3
Created on : 11/21/2006
Published on : 11/21/2006
Exists online : False
Views : 269