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An entry in a drop-down list box on a Web page in Internet Explorer 6 is not selected when you press a keyboard key


View products that this article applies to.

Symptoms

If you press a key on your keyboard to select an entry in a drop-down list box on a Web page in Microsoft Internet Explorer 6, the selection in the drop-down list box does not move to the next entry that begins with the pressed key.

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Cause

This issue may occur when one of the following conditions is true:
  • You use the English version of a Windows operating system with the Regional and Language Options set to Japanese.
  • You use the Japanese version of a Windows operating system.

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Resolution

Hotfix information (English version)

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name
   --------------------------------------------------------
   14-Jun-2004  14:31  6.0.2800.1444  2,691,584  Mshtml.dll
				

Hotfix information (Japanese version)

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The Japanese version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name
   --------------------------------------------------------
   14-Jun-2004  14:34  6.0.2800.1444  2,691,584  Mshtml.dll
				
Important note After you install this hotfix, follow the steps that are listed in the "More Information" section of this article to set the iexplore.exe registry key and to activate the hotfix.

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Status

Microsoft has confirmed that this is a problem in Microsoft Internet Explorer 6.

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More information

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
To activate this hotfix, follow these steps:
  1. Exit Internet Explorer.
  2. Click Start, and then click Run.
  3. In the Open box, type regedit, and then click OK.
  4. Locate, and then click to select the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main
  5. With the Main subkey selected, point to New on the Edit menu, and then click Key.
  6. Type FeatureControl, and then press ENTER.
  7. With the FeatureControl subkey selected, point to New on the Edit menu, and then click Key.
  8. If you use Internet Explorer 6 SP1, type SELECT_KEY_KB818614, and then press ENTER.

    If you use Microsoft Windows XP Service Pack 2 or a later version, type FEATURE_SELECT_KEY_KB818614, and then press ENTER.
  9. With the registry subkey that you created in step 8 selected, point to New on the Edit menu, and then click DWORD Value.
  10. Type Iexplore.exe, and then press ENTER.
  11. Right-click Iexplore.exe, and then click Modify.
  12. In the Value data box, type 1, and then click OK.
  13. On the File menu, click Exit to close Registry Editor.

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Keywords: KB818614, kbbug, kbfix, kbie600presp2fix, kbie600sp2fix, kbqfe, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 818614
Revision : 8
Created on : 11/15/2007
Published on : 11/15/2007
Exists online : False
Views : 358