Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive an "Unspecified error" error message when SQL Server accesses a linked server that uses Microsoft OLE DB provider for Jet 4.0


Symptoms

When you run a linked server query that is configured to use Microsoft OLE DB provider for Jet 4.0, the query might fail and you receive the following error message:

Error 7399: OLE DB provider 'Microsoft.Jet.OLEDB.4.0' reported an error.
[OLE/DB provider returned message: Unspecified error]
OLE DB error trace [OLE/DB Provider 'Microsoft.Jet.OLEDB.4.0' IDBInitialize::Initialize returned 0x80004005: ].


When you locate and access the linked server in SQL Server Enterprise Manager, you might receive the following error message:

Error 7399: OLE DB provider 'Microsoft.Jet.OLEDB.4.0' reported an error.

↑ Back to the top


Cause

You have the wrong version of Microsoft Jet 4.0 (Msjet40.dll) on the database server.

↑ Back to the top


Resolution

This problem has been fixed in the latest edition of the Jet Service Pack. For additional information about how to obtain the latest version of the Jet 4.0 database engine, click the following article number to view the article in the Microsoft Knowledge Base:

239114 How To: Obtain the Latest Service Pack for the Microsoft Jet 4.0 Database Engine


324944 List of MDAC Fixes in Windows 2000 Service Pack 3

↑ Back to the top


References

For additional information about the occurrence of error message 7399, click the following article numbers to view the articles in the Microsoft Knowledge Base:
814398 PRB: Error 7399 When You Run a Linked Server Query That Uses the OLE DB Provider for Microsoft Jet
296711 PRB: "Unspecified error" Error 7399 Using OPENROWSET Against Jet Database


For additional information about the maintenance of Jet 4.0, click the following article number to view the article in the Microsoft Knowledge Base:
300216 HOW TO: Keep a Jet 4.0 Database in Top Working Condition

↑ Back to the top


Keywords: kbappliestoyukon, kbyukonsweep, kbtshoot, kbsweptjet4sp, kbjet, kberrmsg, kbwiprotr, kbwiproauthor, kbprb, kb

↑ Back to the top

Article Info
Article ID : 818182
Revision : 3
Created on : 4/20/2018
Published on : 4/20/2018
Exists online : False
Views : 284