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XADM: Incorrect Origination Times Are Displayed in the Message Tracking Logs


View products that this article applies to.

Symptoms

In Exchange 2000, when you try to use the message tracking logs to track message delivery times in your organization, you may notice that incorrect times appear in the Origination Time field of the message tracking log.

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Cause

This problem occurs when a message is sent from one Exchange 2000 virtual server to another virtual server in the same Exchange 2000 organization. For example, this problem occurs if you send a message across one bridgehead server to another bridgehead server in the same Exchange 2000 organization, or if you send a message between two Exchange 2000 servers in the same routing group.

The message origination time that appears in the Origination Time field is defined as the "timestamp when the message first entered the Exchange 2000 organization (either from an external gateway or through creation through a client)." The contents of this field should not change because the origination time can be used to calculate the age of the message in the organization.

However, in Exchange 2000, the contents of the Origination Time field are rewritten on each message hop. Because of this behavior, when you try to use the message tracking logs to calculate the total time that a message has spent in the Exchange 2000 organization, you cannot calculate it correctly.

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Resolution

Cumulative Rollup Information

To resolve this problem, obtain the September 2003 Exchange 2000 Server Post-Service Pack 3 (SP3) Rollup. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824282 September 2003 Exchange 2000 Server Post-Service Pack 3 Rollup

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. Component: Transport

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version      Size     File name
------------------------------------------------------
07-Jul-2003  16:06  6.0.6484.0   131,072  Drviis.dll
07-Jul-2003  16:09  6.0.6484.0   307,200  Exsmtp.dll
07-Jul-2003  16:04  6.0.6484.0    94,208  Peexch50.dll
07-Jul-2003  16:05  6.0.6484.0   393,216  Phatcat.dll
07-Jul-2003  16:07  6.0.6484.0   528,384  Reapi.dll
07-Jul-2003  16:09  6.0.6484.0   311,296  Resvc.dll
Note Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3 (SP3). For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
301378 How to Obtain the Latest Exchange 2000 Server Service Pack

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

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Keywords: KB818017, kbbug, kbexchange2000presp4fix, kbfix, kbqfe, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 818017
Revision : 8
Created on : 10/26/2006
Published on : 10/26/2006
Exists online : False
Views : 213