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FIX: Passive Mode FTP May Break with Multiple IP Addresses on External Interface


View products that this article applies to.

Symptoms

Internal SecureNAT and Internet Security and Acceleration Server (ISA) Firewall clients may not open the FTP data connection to an FTP server that is using passive mode FTP (PASV). The FTP server may return one of the following error messages:
426 Connection closed; transfer aborted.
-or-
425 Can't open data connection.
In some circumstances, the FTP client may seem to stop responding (hang) or time out. FTP clients that use active mode FTP (PORT) work without error.

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Cause

When the client establishes a passive mode FTP connection to an FTP server, the client must establish both connections. The FTP server returns the TCP port used for the FTP data connection. The FTP server expects this FTP data connection to come from the same IP address as the FTP control channel. If the connection comes from a different IP address, the FTP server may reject or close the connection because this may be a passive mode port theft attempt.

When ISA has more than one IP address bound to the external interface, the source IP address for the FTP data connection may not be the primary IP address. Instead, the source IP address may be one of the secondary IP addresses bound to the external interface. With the hotfix installed, ISA always uses the primary IP address for both types of connections.

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Resolution

You must install ISA Server Service Pack 1 (SP1) before you install the following hotfix.

For additional information about how to obtain the latest ISA Server service pack, click the article number below to view the article in the Microsoft Knowledge Base:
313139 How to Obtain the Latest Internet Security and Acceleration Server 2000 Service Pack
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size    File name
   -----------------------------------------------------
   02-Apr-2003  11:52  3.0.1200.260  19,216  Ftpfltr.dll      
This fix also applies to the French, German, Spanish, and Japanese versions of ISA Server.

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Workaround

To work around the problem, use one of the following methods:
  • Only bind one IP address to the external interface.
  • Disable IP routing:
    1. In the ISA MMC, expand Servers and Arrays.
    2. Expand the server name node, and then expand Access Policy.
    3. Right-click IP Packet Filters, and then click Properties.
    4. Click the General tab, and then click to clear the Enable IP routing check box.
    5. Click OK to close the dialog box.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

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Keywords: KB817829, kbprb, kbfix, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 817829
Revision : 8
Created on : 6/14/2007
Published on : 6/14/2007
Exists online : False
Views : 326