Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"Setup Was Unable to Format the Drive" error message appears during ASR restore


View products that this article applies to.

Symptoms

While you are performing an Automated System Recovery (ASR) restore on an Itanium computer (IA64), you may receive the following error message:
Setup was unable to format the drive
The ASR process formats one partition completely. ASR seems to format the second partition correctly, but then you receive the error message. At this point, you must restart the computer. But, because the operating system partition (the boot partition) has already been formatted, you cannot successfully restart the computer.

↑ Back to the top


Cause

The first partition that is formatted is the partition where the operating system is. The second partition that is formatted is the Extensible Firmware Interface (EFI) System Partition, but the formatting process fails because the ASR.sif file that is on the ASR floppy disk has the wrong value listed for "sectors per cluster."

↑ Back to the top


Resolution

The resolution that this article describes is a preventative measure. If you are in a situation where you must restore to gain access to the operating system again, see the "Workaround" section of this article.

Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Syssetup.dll5.2.3790.501,833,98406-Jun-200316:10IA- 64

Windows XP

Service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 1 (SP1) installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Syssetup.dll5.1.2600.12321,807,87206-Jun-200316:17IA- 64

↑ Back to the top


Workaround

To work around this issue, correct the ASR.sif file so that you can start the ASR restore process on the computer.

This procedure uses an example ASR.sif file. The ASR.sif file that you use will look similar, but the numbers will be different. Put the ASR floppy disk that was created during the ASR backup process in another computer. Open the ASR.sif file in a text editor, such as Notepad. The relevant section of ASR.sif will be similar to the following:
[PARTITIONS.GPT]
1=1,0,2,,"c12a7328-f81f-11d2-ba4b-00a0c93ec93b","0a575940-189b-01c3-92e0-3c772e43ac40",0x1,"EFI system partition",0x06,63,706797,0x1000
2=1,1,0,,"e3c9e316-0b5c-4db8-817d-f92df00215ae","a142f920-1af0-01c3-a1f4-04622fd5ec6d",0x0,"Microsoft reserved partition",0x00,706860,257040,0x0
3=1,2,1,,"ebd0a0a2-b9e5-4433-87c0-68b6b72699c7","b126f760-1af0-01c3-92e0-3c772e43ac40",0x0,"Basic data partition",0x07,963900,20482875,0x1000
Note The lines in this example wrap for readability.

The only significant line is the EFI system partition line:
1=1,0,2,,"c12a7328-f81f-11d2-ba4b-00a0c93ec93b","0a575940-189b-01c3-92e0-3c772e43ac40",0x1,"EFI system partition",0x06,63,706797,0x1000
The EFI system partition is the partition that it is failing to format. You must know the size of this partition. Take the value 706797 (the second-last number on that line) and multiply it by 512. This equals 361,880,064. This means that the example system has an EFI system partition of about 361 MB. Compare this value to the following table:

	   Drive size            
(logical volume)      FAT type   Sectors     Cluster size (decimal)     Cluster size (hexadecimal)
------------------------------------------------------------------------------------------
15 MB or less         12-bit       8           4096                      0x1000
16 MB - 127 MB        16-bit       4           2048                      0x800
128 MB - 255 MB       16-bit       8           4096                      0x1000
256 MB - 511 MB       16-bit      16           8192                      0x2000
512 MB - 1,023 MB     16-bit      32          16384                      0x4000
1,024 MB - 2,048 MB   16-bit      64          32768                      0x8000

This means that you must format this example partition with 8-KB clusters (8,192 bytes). However, the file says to format it as 4-KB clusters (4096 bytes) (the last number in the same line, 0x1000, equals 4,096 in decimal form). Therefore, you must change the 0x1000 to 0x2000 (the decimal equivalent of 0x2000 is 8,192).

The new version of the line is:
1=1,0,2,,"c12a7328-f81f-11d2-ba4b-00a0c93ec93b","0a575940-189b-01c3-92e0-3c772e43ac40",0x1,"EFI system partition",0x06,63,706797,0x2000

Save the file, and then start the ASR restore process with the modified ASR floppy disk. The process should now complete successfully.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

↑ Back to the top


References

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
820364 The Setupldr.efi file cannot read the Automated System Recovery disk or the Winnt.sif file from a USB floppy drive in Windows Server 2003

↑ Back to the top


Keywords: KB817708, kbwinserv2003presp1fix, kbqfe, kbfix, kbbug, kbhotfixserver, kbwinxppresp2fix, kbautohotfix

↑ Back to the top

Article Info
Article ID : 817708
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 537