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XCON: Incorrect NDR Is Returned When You Send a Message to a Mailbox Where a Delivery Restriction Is Based on Distribution Group Membership


View products that this article applies to.

Symptoms

You receive a non-delivery report (NDR) in the following scenario:
You create a delivery restriction on a mailbox that is based on distribution group membership where you permit only messages from members of that distribution group.

-and-
You send a message to the mailbox recipient from a recipient who is not a member of the distribution group.
This behavior is expected. However, the NDR incorrectly states why the message was not delivered. For example, you may receive an NDR that is similar to the following:
The e-mail account does not exist at this organization.

<server.domain.com #5.1.1>
You expect to receive an NDR that is similar to the following:
You do not have permission to send to this recipient.

<server.domain.com #5.7.1>
If you increase diagnostic logging to its maximum level for the following components
MSExchangeTransport
Connection Manager
Queuing Engine
the following events appear in the application log of Event Viewer:

Event Type: Warning
Event Source: MSExchangeTransport
Event Category: Queuing Engine
Event ID: 4004
Date: date
Time: time
User: N/A
Computer: server
Description:
Categorization failed. The error message is 'The system cannot find the file specified.'.
Data:
0000: 02 00 00 00 ....

-and-

Event Type: Warning
Event Source: MSExchangeTransport
Event Category: Connection Manager
Event ID: 756
Date: date
Time: time
User: N/A
Computer: server
Description:
A non-delivery report with a status code of 5.1.1 was generated for
recipient RFC822;user@domain.com (Message-ID
<05F01BE6F1F26C41B55908C37BA7C5971CD297@domain.com>).>
Data:
0000: 02 00 07 80 ....

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Cause

This problem occurs if both of the following conditions exist:
The recipient is in an organizational unit that has a non-ASCII character in its distinguished name (DN). For example, the organizational unit name contains an umlaut character.

-and-
The distribution group contains many members. For example, the distribution group contains more than 1,000 members.
In this scenario, the Exchange message categorizer cannot expand the distribution group to determine group membership.

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Resolution

Cumulative Rollup Information

To resolve this problem, obtain the September 2003 Exchange 2000 Server Post-Service Pack 3 (SP3) Rollup. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824282 September 2003 Exchange 2000 Server Post-Service Pack 3 Rollup

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange 2000 Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Component: Message Categorizer

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   --------------------------------------------------
   24-Apr-2003  00:40  6.0.6458.0  503,808  Phatq.dll
Note Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3 (SP3). For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
301378 How to Obtain the Latest Exchange 2000 Server Service Pack

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Status

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

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Keywords: KB817425, kbbug, kbexchange2000presp4fix, kbfix, kbqfe, kbqfe, kbhotfixserver

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Article Info
Article ID : 817425
Revision : 5
Created on : 10/26/2006
Published on : 10/26/2006
Exists online : False
Views : 195