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Microsoft Exchange IMAP4 service stops responding on a heavily loaded server


View products that this article applies to.

Symptoms

On a heavily loaded Exchange 2000 server, you may experience one or more of the following symptoms:
  • The Microsoft Exchange IMAP4 service may stop responding to client requests.
  • The Microsoft Exchange EXIPC (Epoxy) Blocks Allocated performance monitoring counter for the IMAP instance increases from 0 (zero) to 100,000 in a short time (typically, less than 10 minutes). After continued heavy usage (stress), the counter increase again (typically from 100,000 to 200,000 in less than 10 minutes).
  • If you try to restart Microsoft Windows, the Exchange IMAP4 service stops responding.
  • An Access Violation (AV) occurs in the Inetinfo.exe file process.

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Cause

This problem may occur if the Epoxy queue becomes full, for example, when many IMAP clients browse through a heavily populated public folder list.

The code that determines when the Epoxy queue is full incorrectly determines this state, so that a full queue condition is not detected.

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Resolution

Cumulative Rollup Information

To resolve this problem, obtain the September 2003 Exchange 2000 Server Post-Service Pack 3 (SP3) Rollup. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824282 September 2003 Exchange 2000 Server Post-Service Pack 3 Rollup

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version       Size   File name
----------------------------------------------------------
21-Mar-2003  21:11  6.0.6444.0  733,184  Epoxy.dll
Note Because of file dependencies, this update requires Exchange 2000 Server Service Pack 3 (SP3).

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
301378 How to Obtain the Latest Exchange 2000 Server Service Pack

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

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More information

For additional information about the Exchange Server Epoxy component, click the following article number to view the article in the Microsoft Knowledge Base:
260995 XCON: Definitions of Key Transport Components in Exchange 2000 Server

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Keywords: KB817051, kbbug, kbexchange2000presp4fix, kbfix, kbqfe, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 817051
Revision : 10
Created on : 2/20/2007
Published on : 2/20/2007
Exists online : False
Views : 217