Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The IMAP4 service stops responding when you try to restart it and stops responding to client requests


View products that this article applies to.

Symptoms

On a heavily loaded Exchange 2000 Server public folder server, the Microsoft Exchange Internet Message Access Protocol 4 (IMAP4) service may stop responding to client requests. You may experience one or more of the following symptoms:
  • Microsoft Outlook Express or other IMAP4 clients receive error messages similar to the following when they try to list public folders:
    Your Server has not responded within 60 seconds.
  • The Information Store process (Store.exe) uses an excessive amount of memory.
  • Events similar to the following appear in the Application log of the Event Viewer:
    Event Category: Performance
    Event ID: 9582
    Type: Error
    Description: The virtual memory necessary to run your Exchange server is fragmented in such a way that normal operation may begin to fail. It is highly recommended that you restart all Exchange services to correct this issue.

    For more information, click http://search.support.microsoft.com/search/?adv=1.
  • When you try to stop the Exchange IMAP4 service, or restart the server, the IMAP4 service stops responding (hangs).

↑ Back to the top


Cause

This problem may occur if the IMAP4 service assigns a value of 0xFFFF for the crowTotal field in the EcQueryRows function. This allocates memory in 9 megabyte (MB) portions as IMAP4 responds to client requests. Because of this, on a heavily loaded server, memory may become fragmented or exhausted.

↑ Back to the top


Resolution

To resolve this problem, the value for the crowTotal field has been changed from 0xFFFF to 0x800.

Cumulative Rollup Information

To resolve this problem, obtain the September 2003 Exchange 2000 Server Post-Service Pack 3 (SP3) Rollup. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824282� September 2003 Exchange 2000 Server Post-Service Pack 3 Rollup

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version            Size    File name
------------------------------------------------------------
25-Mar-2003  02:43  6.0.6445.0         90,112  Eximap4.dll
25-Mar-2003  02:43  6.0.6445.0         32,768  Expop3.dll
25-Mar-2003  02:44  6.0.6445.0         32,768  Exproto.dll
24-Mar-2003  19:57  6.0.6445.0         40,960  Febecfg.dll 
25-Mar-2003  02:43  6.0.6445.0         32,768  Iisif.dll 
25-Mar-2003  02:44  6.0.6445.0        135,168  Iisproto.dll
25-Mar-2003  02:45  6.0.6445.0         61,440  Imap4be.dll
24-Mar-2003  20:41  6.0.6445.0        319,488  Imap4evt.dll
24-Mar-2003  20:06  6.0.6445.0        131,072  Imap4fe.dll
25-Mar-2003  02:43  6.0.6445.0        126,976  Imap4svc.dll
25-Mar-2003  02:43  6.0.6445.0         36,864  Pop3be.dll
24-Mar-2003  20:41  6.0.6445.0        303,104  Pop3evt.dll
24-Mar-2003  20:09  6.0.6445.0         24,576  Pop3fe.dll
25-Mar-2003  02:41  6.0.6445.0         73,728  Pop3svc.dll
24-Mar-2003  20:41  6.0.6445.0        163,840  Protomsg.dll
Note Because of file dependencies, this update requires Exchange 2000 Server Service Pack 3 (SP3).

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
301378� How to Obtain the Latest Exchange 2000 Server Service Pack

↑ Back to the top


Status

Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.

↑ Back to the top


Keywords: KB817050, kbbug, kbexchange2000presp4fix, kbfix, kbqfe, kberrmsg, kbprb, kbqfe, kbhotfixserver, kbautohotfix

↑ Back to the top

Article Info
Article ID : 817050
Revision : 6
Created on : 2/20/2007
Published on : 2/20/2007
Exists online : False
Views : 201