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Roaming profiles may not unload after you use WMI on a Windows Server 2003-based computer or a Windows XP-based computer


View products that this article applies to.

Symptoms

When you log off a Roaming Profile User account, the logoff process may take longer than expected to complete.

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Cause

When you enumerate certain classes in Windows Management Instrumentation (WMI), this may result in an open handle to the HKEY_CURRENT_USER registry hive in the WMI provider host (Wmiprvse.exe) at user logoff. This may prevent roaming profiles from being unloaded and saved. These WMI classes are typically enumerated by system management programs to determine system configuration and status.

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Resolution

Windows Server 2003

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Windows XP

Service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389� How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size     File name
   ---------------------------------------------------------
   17-Mar-2003  19:52  5.1.2600.1187   203,776  Wmiprvse.exe
   20-Mar-2003  08:47  5.82.2800.1187  533,504  Comctl32.dll
   17-Mar-2003  19:54  6.0.2800.1187   921,600  Comctl32.ocx				

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

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Keywords: kbautohotfix, kbqfe, kbwinxpsp2fix, kbqfe, kbwinxppresp2fix, kbfix, kbbug, kbhotfixserver, KB816880

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Article Info
Article ID : 816880
Revision : 7
Created on : 8/29/2007
Published on : 8/29/2007
Exists online : False
Views : 276