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Poor Program Performance Occurs in a Remote Terminal Services Session


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Symptoms

When you run a program in a remote Terminal Services session, you may experience any of the following symptoms:
  • Poor performance
  • Excessive CPU usage
  • Reduced animations (flat text instead of bitmaps)

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Cause

This issue may occur if you are using a program such as Microsoft Office and the SPI_GETUIEFFECTS setting is turned on. This setting is turned on by default during a Windows Server 2003 Terminal Services session. However, this setting is not turned on by default during a Windows 2000 Terminal Services session. Programs may be optimized or may rely on this setting to reduce the effect that a Terminal Services session has on bandwidth. This setting provides details about animation in the program.

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Resolution

To resolve this issue, use Compatibility Administrator Tool. Compatibility Administrator Tool is included in Application Compatibility Toolkit 5.0.

Note For information about how to obtain and install Application Compatibility Toolkit, visit the following Microsoft Web site: To obtain the toolkit, visit the following Microsoft Web site:You can use Compatibility Administrator to supply a command-line value to change the EmulateGetUiEffects setting to FALSE for programs that run remotely. To do this, follow these steps:
  1. Click Start, point to All Programs, point to Microsoft Windows Application Compatibility Toolkit, and then click Compatibility Administrator Tool 3.0.
  2. Create a new custom database. To do this, follow these steps:
    1. In Compatibility Administrator Tool, click New on the File menu.
    2. On the Edit menu, click Rename.
    3. Type a name for the database, and then press ENTER.
    4. On the File menu, click Save.
    5. Type a name for the file, and then click Save.
  3. Create a new application fix. To do this, follow these steps:
    1. On the Database menu, point to Create New and then click Application Fix.
    2. In the Name of the program to be fixed box, type the name of the program.
    3. In the Name of the vendor for this program box, type the name of the vendor for the program.
    4. Click Browse to select the program file location for the program, and then click Open
    5. Click Next, and then click Next again.
    6. In the Compatibility fixes box, click to select EmulateGetUiEffects, and then click Next.
    7. If you want to test the program after the fix is applied and you want to supply a command-line value, click Test Run.
    8. Click Finish.
    9. On the File menu, click Save.
After you create the new custom database and the new application fix, you must copy the database file to each computer where the program runs. You must then register the information that is contained in the file on each computer. You can use the Sdbinst.exe command-line utility to register the fix. To use Sdbinst.exe, from a command prompt, type sdbinst followed by the full path and name of the custom .sdb file. For example, type the following command:
sdbinst "c:\windows\apppatch\myapp.sdb"
After the file is registered on a computer, its compatibility information is used every time the program starts on that computer.

For additional information about Sdbinst.exe, click the following article number to view the article in the Microsoft Knowledge Base:
308235 How to Use the Compatibility Database Installer Tool in Windows XP

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Keywords: KB816513, kbprb, kbtermserv, kbwinservperf

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Article Info
Article ID : 816513
Revision : 9
Created on : 5/9/2007
Published on : 5/9/2007
Exists online : False
Views : 269