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"Your Interactive Logon Privilege Has Been Disabled" Error When You Try to Log on to a Terminal Server


View products that this article applies to.

Symptoms

When you try to log on to a Microsoft Windows 2003-based terminal server, you may receive the following error message:
Your interactive logon privilege has been disabled. Please contact your system administrator.

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Cause

This issue may occur if you try to use the Guest user account to log on after you add the account to the built-in Remote Desktop Users security group. You may also receive this error if you try to log on by using any user account that is denied Read permissions to Active Directory directory service.

This behavior occurs because the domain Guest user account is denied Read permissions to their user account information in Active Directory. When an account is denied the Read permission to their Active Directory or local account information in the Windows Security Account Manager (SAM) database, the logon request is unsuccessful because the operating system cannot determine if the user has permission to log on to Windows.

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Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

For 32-bit systems

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   21-Jul-2004  23:38  5.2.3790.193      540,672  Winlogon.exe     
   19-Jul-2004  06:32                        271  Branches.inf
   22-Jul-2004  05:12                      9,766  Kb815266.cat
   20-Jul-2004  03:21                        354  Updatebr.inf
   22-Jul-2004  03:31                      5,657  Update_rtmqfe.inf

For 64-bit systems

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   19-Jul-2004  09:30  5.2.3790.193      638,464  Winlogon.exe     IA64
   18-Jul-2004  21:22                        271  Branches.inf
   22-Jul-2004  05:12                      9,766  Kb815266.cat
   22-Jul-2004  03:45                        354  Updatebr.inf
   22-Jul-2004  03:45                      5,677  Update_rtmqfe.inf

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Workaround

To work around this issue, edit the Windows registry on the terminal server so that it causes the Winlogon process to ignore errors reading the Terminal Services Configuration data, and so that it reads the DefaultUserConfig data instead. To do so, follow these steps.

Warning: After you follow these steps, a user account whose Read permissions to the local SAM database or to Active Directory, you have intentionally removed to prevent their logon to the terminal server, will be able to log on to the terminal server.
  1. Click Start, click Run, type regedit in the Open box, and then click OK.

    Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
    322756 How to back up and restore the registry in Windows
  2. Locate the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. In the New Value #1 box, type IgnoreRegUserConfigErrors, and then press ENTER.
  5. Right-click IgnoreRegUserConfigErrors, and then click Modify.
  6. In the Value data box, type 1 (one), click Decimal, and then click OK.
  7. Quit Registry Editor.

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Keywords: KB815266, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 815266
Revision : 16
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 537