Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Web Proxy Service Stops Responding Intermittently After You Install Websense


View products that this article applies to.

Symptoms

The Web Proxy Service (W3Proxy.exe) may stop servicing requests on your Microsoft Internet Security and Acceleration (ISA) 2000 Server. Additionally, you may experience the following behaviors:
  • You can still connect to the internal interface by using the Ping.exe utility ("Ping" the internal interface). However, if you try to perform a "Net Use" command against the internal interface, you receive an Error code 67 message that is similar to the following:
    Logon to \\servername\sharename failed: code 67.
  • When you try to stop or start ISA Server 2000-related services, you receive an Error code 1053 message that is similar to the following:
    Could not stop the service servicename on Local Computer. Error 1053: The service did not respond to the start or control request in a timely fashion.
  • If you disable, and then enable the network adapter you can stop and restart the ISA Server 2000 services.

↑ Back to the top


Cause

This issue may occur if you install the Websense Internet Filtering program on your ISA 2000 Server-based computer.

↑ Back to the top


Resolution

To resolve this issue, upgrade to the latest version of Websense. Websense version 4.4.0 and later have an improved socket allocation algorithm to minimize the number of Internet Information Services (IIS) threads that wait on a single connection (semaphore).

For information about how to contact Websense Inc., visit the following Websense Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

↑ Back to the top


More information

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

↑ Back to the top


Keywords: KB814756, kbprb, kbbug, kberrmsg

↑ Back to the top

Article Info
Article ID : 814756
Revision : 4
Created on : 10/30/2006
Published on : 10/30/2006
Exists online : False
Views : 375